1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[XFCE] Xfce 4.6 window redraw slow and heavy on CPU

Discussion in 'Other Window Managers' started by kasse, Feb 19, 2010.

  1. kasse

    kasse New Member

    Messages:
    22
    Thanks Received:
    0
    I installed xfce 4.6.1 on FreeBSD x64_8.0 and the windows are being redrawn very slowly when moving or scrolling. The CPU usage is really high when doing something with the windows.

    I found something that this could have with the option "composite extension" from the xfce faq and gentoohttp://wiki.xfce.org/faq http://forums.gentoo.org/viewtopic-p-5741372.html?sid=a67fd294952582d65c73199582f201c9, so I disabled it in xorg.conf.

    Unfortunately there were no changes.

    I read that the radeonhd driver was slowhttp://lists.freebsd.org/pipermail/freebsd-questions/2009-December/209048.html should I switch driver?

    Here are relevant parts of my xorg.conf
    Code:
    Section "Module"
            Load  "extmod"
            Load  "record"
            Load  "dbe"
            Load  "glx"
            Load  "dri"
            Load  "dri2"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "NoAccel"                   # [<bool>]
            #Option     "AccelMethod"               # [<str>]
            #Option     "offscreensize"             # [<str>]
            #Option     "SWcursor"                  # [<bool>]
            #Option     "ignoreconnector"           # [<str>]
            #Option     "forcereduced"              # [<bool>]
            #Option     "forcedpi"                  # <i>
            #Option     "useconfiguredmonitor"      # [<bool>]
            #Option     "HPD"                       # <str>
            #Option     "NoRandr"                   # [<bool>]
            #Option     "RROutputOrder"             # [<str>]
            #Option     "DRI"                       # [<bool>]
            #Option     "TVMode"                    # [<str>]
            #Option     "ScaleType"                 # [<str>]
            #Option     "UseAtomBIOS"               # [<bool>]
            #Option     "AtomBIOS"                  # [<str>]
            #Option     "UnverifiedFeatures"        # [<bool>]
            #Option     "Audio"                     # [<bool>]
            #Option     "HDMI"                      # [<str>]
            #Option     "COHERENT"                  # [<str>]
            Identifier  "Card0"
            Driver      "radeonhd"
            VendorName  "ATI Technologies Inc"
            BoardName   "RV710 [Radeon HD 4350]"
            BusID       "PCI:1:0:0"
            Option      "DRI"
            Option      "AccelMethod" "exa"
    EndSection
    
    Section "Extensions"
            Option "Composite" "Disable"
    EndSection
    


    I used xmonad before and there were no such problems except that xmonad somehow crashed or locked. Then again with a tiling manager you don't move the windows and with my xmonad there was no fancy graphics.
     
  2. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,765
    Thanks Received:
    1,870
    Please use for file/path names, and
    Code:
     for system output and file contents.
     
    kasse thanks for this.
  3. adamk

    adamk New Member

    Messages:
    1,624
    Thanks Received:
    265
    Can you attach or pastebin your /var/log/Xorg.0.log file?

    EDIT: Also, I would recommend the 'radeon' driver unless you need HDMI audio from the video card. And, finally, your xorg.conf file has this:

    Code:
            Option      "DRI"
            Option      "AccelMethod" "exa"Section "Extensions"
    EndSection
    
    Section "Extensions"
    


    That's definitely wrong. Remove the 'Section "Extensions"'from the Option line.

    Adam
     
  4. kasse

    kasse New Member

    Messages:
    22
    Thanks Received:
    0
    The xorg.conf was just an error when I pasted it in this post.

    It is fixed now i hope.
    From what I can see there are no errors in xorg.0.log
    Here it ishttp://pastebin.ca/1803238

    I have tried different drivers with no effect and also variations with/withoud dri&exa
     
  5. thuglife

    thuglife New Member

    Messages:
    160
    Thanks Received:
    40
    Use x11-drivers/xf86-video-ati driver

    Add WITHOUT_NOUVEAU=yes to /etc/make.conf

    Update your installed software (# portmaster -aD)

    Add

    Code:
    Section "ServerFlags"
            Option  "AIGLX" "true"
    EndSection


    at your /etc/X11/xorg.conf
     
    kasse thanks for this.
  6. kasse

    kasse New Member

    Messages:
    22
    Thanks Received:
    0
    Well it is working fine now
    except for the aiglx:

    Code:
    (EE) AIGLX error: dlopen of /usr/local/lib/dri/r600_dri.so failed (Cannot open "/usr/local/lib/dri/r600_dri.so")
    


    The ati chooses the radeon driver, which I tried before without success.

    I am still confused why it works now? (I had rebuilt the x-drivers just yesterday so it must be someting else??)

    p.s. It is also working with radeonhd now.

    Thanks!!!
     
  7. fronclynne

    fronclynne New Member

    Messages:
    1,297
    Thanks Received:
    167
    Code:
    > pkg_info -W /usr/local/lib/dri/r600_dri.so 
    /usr/local/lib/dri/r600_dri.so was installed by package dri-7.6.1,2

    (for which see the WITHOUT_NOUVEAU bits of /usr/ports/UPDATING)