1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[XFCE] autostart of conky

Discussion in 'Other Window Managers' started by lockdoc, Dec 23, 2009.

  1. lockdoc

    lockdoc New Member

    Messages:
    124
    Likes Received:
    0
    I have some problems autostarting conky.

    I added the conky script to the autostarter (via session and startup) and it resides in /home/user/.config/autostart/conky

    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Version=0.9.4
    Type=Application
    Name=conky
    Comment=
    Exec=/usr/loca/bin/conky
    StartupNotify=false
    Terminal=false
    Hidden=false
    
    The Problem is, that it starts in the background, but is not being displayed on the desktop (after starting the computer physically)
    If I kill x and start it again it works, but not after a real boot.

    My other idea was to put it into the /home/user/.xinitrc.
    Code:
    conky &
    startxfce4
    
    If i do startx, i can see conky starting, but then the desktop wallpaper puts itself "over" conky and conky is no longer visible.

    How do you automatically start conky on your machine?
     
  2. Beastie

    Beastie Member

    Messages:
    1,916
    Likes Received:
    1
    I think it's starting fine but the desktop is being redrawn by xfdesktop.

    In your .conkyrc, enable double buffering (double_buffer yes).
    And if it still doesn't work, try changing own_window_type to override.
     
  3. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,626
    Likes Received:
    14
    I have those settings, but if I start conky from .xinitrc, it always starts in its own window instead of blending with the desktop. I'm now simply starting conky with a launcher after XFCE has started ;) Works fine.
     
  4. lockdoc

    lockdoc New Member

    Messages:
    124
    Likes Received:
    0
    what launcher are u using?
     
  5. Beastie

    Beastie Member

    Messages:
    1,916
    Likes Received:
    1
    Probably because you're missing own_window no, which uses the desktop instead of creating a separate window.
     
  6. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,626
    Likes Received:
    14
    Oh, I tried 'own_window no', but that results in a cat and mouse game: either I see conky, or I see my desktop icons. When I use the one, I lose the other. They're battling for the foreground, or something.

    So I just created a desktop icon (launcher) for Conky, with the /usr/local/bin/conky command line in it, and it works just fine.
     
  7. vaclinux

    vaclinux New Member

    Messages:
    61
    Likes Received:
    0
    I will share my .conkyrc, i manage to put conky top of wallpaper.
    ~/.confgi/.conkyrc
    I set "background no" in conkyrc, because in my ~/.xinitirc i already run conky in background.
     

    Attached Files:

  8. paulfrottawa

    paulfrottawa New Member

    Messages:
    242
    Likes Received:
    0
    So I tried Conky and I like it.

    conky -C > ~/.conkyrc
    If conkyrc is in /root/ mv it to /home/user/

    killall -SIGUSR1 conky
    PS: change eth0 to your lan card you want to monitor.