1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wireless issue broadcom bwi driver on dell inspiron 2200

Discussion in 'Mobile Computing' started by djsameman, Mar 1, 2011.

  1. djsameman

    djsameman New Member

    Messages:
    4
    Thanks Received:
    0
    Hi all!

    I'm new to FreeBSD, having a success install on my DELL inspiron 2200. I've migrated from UBUNTU and was interested to test how it works in FreeBSD.

    Some issues I haven't figured out is the wireless thing.

    Here is output from pciconf

    Code:
    # pciconf
    
    ...
    
    bwi0@pci0:2:3:0:	class=0x028000 card=0x00051028 chip=0x431814e4 rev=0x02 hdr=0x00
        vendor     = 'Broadcom Corporation'
        device     = 'Broadcom 802.11b/g (BCM4318)'
        class      = network
    ...


    I've followed instructions from several places (with help from google ;-)) to install the correct drivers.

    The issue is now:

    # ifconfig wlan0 up scan

    ... going forever and gives nothing ...

    # ifconfig wlan0

    Code:
    wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	ether 00:14:a5:3c:1e:a3
    	media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
    	status: no carrier
    	ssid "" channel 9 (2452 MHz 11g)
    	country US authmode WPA1+WPA2/802.11i privacy OFF txpower 0 bmiss 7
    	scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7
    	roam:rate 5 protmode CTS


    dmesg output is: (only messages about the interface)

    Code:
    bwi0: <Broadcom BCM4318 802.11b/g Wireless Lan> mem 0xdfdfe000-0xdfdfffff irq 19 at device 3.0 on pci2
    bwi0: [ITHREAD]
    bwi0: BBP: id 0x4318, rev 0x2, pkg 2
    bwi0: MAC: rev 9
    bwi0: PHY: type 2, rev 7, ver 3
    bwi0: RF: manu 0x17f, type 0x2050, rev 8
    bwi0: invalid antenna gain in sprom
    bwi0: WARNING: using obsoleted if_watchdog interface
    ...
    wlan0: Ethernet address: 00:14:a5:3c:1e:a3
    ...
    bwi0: firmware rev 0x0127, patch level 0x000e
    

    Below is my settings in /etc/rc.conf:

    Code:
    # -- sysinstall generated deltas -- # Sun Feb 27 22:10:50 2011
    # Created: Sun Feb 27 22:10:50 2011
    # Enable network daemons for user convenience.
    # Please make all changes to this file, not to /etc/defaults/rc.conf.
    # This file now contains just the overrides from /etc/defaults/rc.conf.
    font8x14="iso15-8x14"
    font8x16="iso15-8x16"
    font8x8="iso15-8x8"
    hostname="djsameman"
    ifconfig_fxp0="DHCP"
    keymap="swedish.iso"
    nfs_client_enable="YES"
    hald_enable="yes"
    dbus_enable="yes"
    gdm_enable="yes"
    gnome_enable="yes" 
    gdm_lang="sv_SE.UTF-8"
    wlans_bwi0="wlan0"
    ifconfig_wlan0="WPA DHCP"
    # -----------------------


    And the settings in /boot/loader.conf

    Code:
    # -----------------------
    if_bwi_load="YES"
    # -----------------------


    And the settings in /etc/wpa_supplicant.conf:

    Code:
    # -----------------------
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    # -----------------------


    I have also done a ports install from /usr/ports/net/bwi-firmware-kmod/

    Still no luck with the wireless. I know there are several working accesspoints.

    So help to a FreeBSD newbie would be appreciated.
     
  2. wblock@

    wblock@ Administrator Staff Member Administrator Moderator Developer

    Messages:
    11,701
    Thanks Received:
    2,266
    That makes it scan, but not show the results.
    # ifconfig wlan0 up list scan

    Those aren't required. A network settings section with an ssid and psk is needed to associate, but scanning should work without it.
     
    djsameman thanks for this.
  3. djsameman

    djsameman New Member

    Messages:
    4
    Thanks Received:
    0
    HI and THANKS! I've done a computer restart and suddenly it worked. Possible explanation can be that the wpa_supplicant.conf file didn't exist first.

    Code:
    # ifconfig wlan0 up scan
    

    gives the desired result.

    Cheers from Sweden.

    Janneman
     
  4. wblock@

    wblock@ Administrator Staff Member Administrator Moderator Developer

    Messages:
    11,701
    Thanks Received:
    2,266
    wpa_supplicant.conf is only used by wpa_supplicant(8), it's not needed for scanning. More likely the reset started from scratch and you had the configuration correct. Might also be something to do with a Fn combination or physical switch to enable the radio. The radio LEDs don't work with all drivers or cards.