1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

usr/src/crypto/openssl/ssl/s3_cbc.c: No such file or directory

Discussion in 'Installing and Upgrading FreeBSD' started by Mayhem30, Apr 3, 2013.

  1. Mayhem30

    Mayhem30 Member

    Messages:
    108
    Likes Received:
    1
    I just finished running freebsd-update install and received this error:

    Code:
    The following files will be added as part of updating to 8.3-RELEASE-p7:
    /usr/src/crypto/openssl/ssl/s3_cbc.c
    ...
    ...
    Installing updates...install: ///usr/src/crypto/openssl/ssl/s3_cbc.c: No such file or directory
    done.
    Is this something for me to worry about?
     
  2. ab

    ab New Member

    Messages:
    16
    Likes Received:
    0
    I encountered the same thing, BUT only with i386 system:

    Code:
    9.1-RELEASE FreeBSD 9.1-RELEASE #0 r243826
    My AMD64 hosts, [now] running the following, were fine:

    Code:
    8.3-RELEASE-p7
    and
    Code:
    9.1-RELEASE-p2
    One bit of trouble is that freebsd-update doesn't register a move from
    Code:
    9.1-RELEASE-p1
    to
    Code:
    9.1-RELEASE-p2
    .
     
  3. Mayhem30

    Mayhem30 Member

    Messages:
    108
    Likes Received:
    1
    This error happened on my AMD64 system - and idea where I can get this missing file?
     
  4. ab

    ab New Member

    Messages:
    16
    Likes Received:
    0
    Alas, I do not know.

    I will add, however, that my i386 install is relatively recent and derived from FreeBSD-9.0-RELEASE-i386-memstick.img, which I used freebsd-update to upgrade to the current:
    Code:
    9.1-RELEASE-p1
     
  5. wydrych

    wydrych New Member

    Messages:
    1
    Likes Received:
    0
    Probably, you have not installed the source tree. It is not an issue if you do not compile your kernel.

    Generally, no. However, if you are using freebsd-update cron, it will send you a security update until you resolve the issue.

    AFAIK, there are two workarounds:
    1. Disable updating /usr/src: edit /etc/freebsd-update.conf, excluding src from Components line.
    2. Create a missing directory: # mkdir -p /usr/src/crypto/openssl/ssl.

    If you are sure that you will not compile the kernel and/or world on this server, you can use workaround 1. The latter workaround is safer.
     
  6. ab

    ab New Member

    Messages:
    16
    Likes Received:
    0
    Option two worked for me.

     
  7. realtime

    realtime New Member

    Messages:
    17
    Likes Received:
    0
    Ditto.