1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Quotas Error

Discussion in 'Storage' started by cachorroyayo, Apr 13, 2012.

  1. cachorroyayo

    cachorroyayo New Member

    Messages:
    9
    Likes Received:
    0
    Hello forum,

    I just installed a '7.4-RELEASE FreeBSD' server. I've recompiled my kernel to support quotas.

    Code:
    cat /usr/src/sys/i386/conf/GENERICQUO | grep -i quo
    options 	QUOTA			# Enable quotas
    

    I have this structure in my /etc/fstab because I had to remove *quotas options from fstab.

    Code:
     cat /etc/fstab 
    # Device		Mountpoint	FStype	Options		Dump	Pass#
    /dev/da0s1b		none		swap	sw		0	0
    /dev/da0s1a		/		ufs	rw	1	1
    /dev/da0s1d		/tmp		ufs	rw		2	2
    /dev/da4s1e		/usr		ufs	rw		2	2
    /dev/da4s1d		/var		ufs	rw		2	2
    /dev/acd0		/cdrom		cd9660	ro,noauto	0	0
    /dev/gvinum/mega	/home		ufs	rw		1	2
    proc			/proc		procfs	rw		0	0
    
    Where /dev/gvinum/mega is gvinum installed partition of 3 disks of 200GB each one.

    When I add 'usrquota,grpquota' or 'userquota,groupquota' in both cases, the server runs into single mode user and suggests modifying /etc/fstab and removing 'quota' options.


    Code:
    quotaon -a
    quotaon: /home not mounted for group quotas
    quotaon: /home not mounted for user quotas
    

    Code:
    [root@perseus /mega/home/eduardo]# quotacheck -a
    quotacheck: /home not mounted for group quotas
    quotacheck: /home not mounted for user quotas
    quotacheck: /home not mounted for group quotas
    quotacheck: /home not mounted for user quotas
    

    When I run the mount command I get this info

    Code:
    #mount
       /dev/da0s1a on / (ufs, local)
       devfs on /dev (devfs, local)
       /dev/da0s1d on /tmp (ufs, local, soft-updates)
      /dev/da4s1e on /usr (ufs, local, soft-updates) 
      /dev/da4s1d on /var (ufs, local, soft-updates)
       /dev/gvinum/mega on /mega/home (ufs, local)
       procfs on /proc (procfs, local)
    
    Code:
    /usr/sbin/repquota /home
    repquota: /home not mounted for user quotas
    Can anybody suggest me an option to set up my quotas?

    Thank you very much.
     
  2. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,392
    Likes Received:
    7
  3. cachorroyayo

    cachorroyayo New Member

    Messages:
    9
    Likes Received:
    0
    Yes, my rc.conf contains this lines about quotas.

    Code:
    enable_quotas="YES"
    check_quotas="YES"
     
  4. cachorroyayo

    cachorroyayo New Member

    Messages:
    9
    Likes Received:
    0
    I've followed these steps. But I have no way to complete the process.
     
  5. cachorroyayo

    cachorroyayo New Member

    Messages:
    9
    Likes Received:
    0
    Look this please

    Code:
     dmesg | grep quota
    mount option <usrquota> is unknown
    mount option <grpquota> is unknown
    mount option <usrquota> is unknown
    mount option <grpquota> is unknown
    
    And this...

    Code:
    [root@perseus /mega/home/eduardo]# cat /etc/fstab 
    # Device		Mountpoint	FStype	Options		Dump	Pass#
    /dev/da0s1b		none		swap	sw		0	0
    /dev/da0s1a		/		ufs	rw	1	1
    /dev/da0s1d		/tmp		ufs	rw		2	2
    /dev/da4s1e		/usr		ufs	rw		2	2
    /dev/da4s1d		/var		ufs	rw		2	2
    /dev/acd0		/cdrom		cd9660	ro,noauto	0	0
    /dev/gvinum/mega	/home		ufs	rw,userquota	1	2
    proc			/proc		procfs	rw		0	0
    
    Thank you very much.
     
  6. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,664
    Likes Received:
    24
  7. cachorroyayo

    cachorroyayo New Member

    Messages:
    9
    Likes Received:
    0
    Sorry DutchDameon,
    I will consider for the next time.
     
  8. cachorroyayo

    cachorroyayo New Member

    Messages:
    9
    Likes Received:
    0
    Hello,

    I don't understand why FreeBSD says

    quotaon -avu /home
    Code:
    quotaon: /home not mounted for user quotas
    quotaon: /home not found in fstab
    
    quotacheck -a
    Code:
    quotacheck: /home not mounted for group quotas
    quotacheck: /home not mounted for user quotas
    quotacheck: /home not mounted for group quotas
    quotacheck: /home not mounted for user quotas
    
    If my /etc/fstab file contains /home partition

    cat /etc/fstab
    Code:
    # Device		Mountpoint	FStype	Options		Dump	Pass#
    /dev/da0s1b		none		swap	sw		0	0
    /dev/da0s1a		/		ufs	rw	1	1
    /dev/da0s1d		/tmp		ufs	rw		2	2
    /dev/da4s1e		/usr		ufs	rw		2	2
    /dev/da4s1d		/var		ufs	rw		2	2
    /dev/acd0		/cdrom		cd9660	ro,noauto	0	0
    /dev/gvinum/mega	/home		ufs	rw,userquota,groupquota	1	1	
    proc			/proc		procfs	rw		0	0
    
    I've followed http://www.freebsd.org/doc/es/books/handbook/book.html#QUOTAS and http://www.freebsddiary.org/quotas.php.

    But I can't complete my process.

    Thank you.
     
  9. cachorroyayo

    cachorroyayo New Member

    Messages:
    9
    Likes Received:
    0
    Sorry I omit this command.

    quota -v
    Code:
    quota: /home not mounted for user quotas
    Disk quotas for user root (uid 0): none
    
    Thank you.