1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with the installation

Discussion in 'Mobile Computing' started by MrBean, Aug 15, 2012.

  1. MrBean

    MrBean New Member

    Messages:
    9
    Likes Received:
    0
    Hi, I tried to install FreeBSD but I was unable to boot it. This is what I got in my screen and it continuously reboot my laptop:

    Code:
    CD Loader 1.2
    
    Building the boot loader arguments
    Looking up /BOOT/LOADER... Found
    Relocating the loader and the BTX
    Starting the BTX loader
    Yesterday, I tried PC-BSD and I got the same problem as seen here http://forums.pcbsd.org/showthread.php?t=16961

    Neither 64bit or 32bit, live or not (normal FreeBSD) doesen't work for me. Still the same problem at the boot stage. My laptop is an Elitebook from HP.

    I tried normal FreeBSD CD in my old PII 266MHz and I encounter the same situation.
     
  2. zhoopin

    zhoopin New Member

    Messages:
    60
    Likes Received:
    0
    Change the BIOS setting:
    • Sets the controller to "IDE mode": SATA: IDE (Not AHCI)
    AND/OR
    • Diable eSATA port

    Maybe it's not relevant, but it's worth to update BIOS.
     
  3. MrBean

    MrBean New Member

    Messages:
    9
    Likes Received:
    0
    Yes the problem is the AHCI. If I set to IDE mode, it can load FreeBSD but the Windows 7 won't start...

    So when FreeBSD can support this feature (AHCI) or is there any alternative?
     
  4. wblock@

    wblock@ Administrator Staff Member Administrator Moderator Developer

    Messages:
    11,205
    Likes Received:
    15
    FreeBSD works fine with AHCI. Windows, OTOH, may only work with what was present when it was installed.
     
  5. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,392
    Likes Received:
    7
    Slightly off-topic help :e
    But this worked for me: http://support.microsoft.com/kb/922976

    When you install Windows it basically disables all other drivers to speed up booting. By changing the setting from AHCI to IDE (or vise verse) Windows can't start because the required driver is disabled. Enable the driver and Windows will happily start with either setting.
     
  6. MrBean

    MrBean New Member

    Messages:
    9
    Likes Received:
    0
    Unfortunately, it doesn't work for me... nothing changed:(
     
  7. zhoopin

    zhoopin New Member

    Messages:
    60
    Likes Received:
    0
    Don't waste your time, Install FreeBSD over virtual machine (VM), Keep working until you find a solution.
    "A good plan violently executed now is better than a perfect plan executed next week." (G. S. Patton) ;)