1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem on start ShoutCast after upgrade

Discussion in 'Installation and Maintenance of Ports or Packages' started by Gerardo, Dec 1, 2009.

  1. Gerardo

    Gerardo New Member

    Messages:
    15
    Likes Received:
    0
    shoutcast to start pulling me this error

    /libexec/ld-elf.so.1: / usr/lib/libpthread.so.1: version LIBTHREAD_1_0 required by / usr / local / sbin / sc_serv not found

    worked fine when I had the version 7.2 and since version 8 upgrade to wing I have the problem.
    ports rebuild.
     
  2. Gerardo

    Gerardo New Member

    Messages:
    15
    Likes Received:
    0
    none?
     
  3. Voltar

    Voltar New Member

    Messages:
    191
    Likes Received:
    0
    Are you using the FreeBSD or Linux binary?

    If you're using the FreeBSD binary, do you have the compat4/5 ports installed? They only compile it on 4.11/5.3 last I checked.

    Personally I've never had luck with the native FreeBSD binary, I've always resorted to using the Linux binary and I've never had issues (don't really run a streaming station anymore though).
     
  4. filipec

    filipec New Member

    Messages:
    1
    Likes Received:
    0
    Hello,

    i got the same problem here, and fixed with the linux version of shoutcast and linux_base.tbz.

    Hope it works for you too.
     
  5. scaturan

    scaturan New Member

    Messages:
    1
    Likes Received:
    0
    I encountered the same issue on FreeBSD 8.1 - installed /usr/ports/misc/compat4x/ and downloaded sc_serv (FreeBSD 4 build from http://www.shoutcast.com/broadcast-tools) and worked. I couldn't get /usr/ports/misc/compat5x/ to work with sc_serv (FreeBSD 5 build)