1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem installing www/webkit-gtk2

Discussion in 'Installation and Maintenance of Ports or Packages' started by hedgehog, Dec 8, 2010.

  1. hedgehog

    hedgehog New Member

    Messages:
    191
    Likes Received:
    0
    I've updated gettext to 0.18 version as it's described in /usr/ports/UPDATING this summer. Everything was OK unless i decided to install gimp.

    Code:
    ===>  Building for webkit-gtk2-1.2.5_1
    /libexec/ld-elf.so.1: Shared object "libintl.so.8" not found, required by "gmake"
    *** Error code 1
    
    Stop in /usr/ports/www/webkit-gtk2.
    *** Error code 1
    Code:
    $ uname -srm
    FreeBSD 8.1-RELEASE amd64
    Code:
    $ pkg_info -xI gettext
    gettext-0.18.1.1    GNU gettext package
    p5-gettext-1.05_3   Message handling functions
    the following command didn't show anything related to missing libintl.so.8 library:
    $ pkg_libchk -R gettext-0.18.1.1

    mapping libintl.so.8 to either libintl.so.9 or an old libintl.so.8 (which I had in backup) via /etc/libmap32.conf didn't help. However, I have different error output now:
    Code:
    ===>  Building for webkit-gtk2-1.2.5_1
    /libexec/ld-elf.so.1: /usr/local/lib/compat/pkg/libintl.so.8: unsupported file layout
    *** Error code 1
    
    Stop in /usr/ports/www/webkit-gtk2.
    *** Error code 1
    Is there anything else I can do about this?
     
  2. wblock@

    wblock@ Administrator Staff Member Administrator Moderator Developer

    Messages:
    11,257
    Likes Received:
    25
    Seems pretty clear that gmake is still trying to use libintl.so.8, which would mean it (gmake) didn't get rebuilt. But maybe it's a 32/64 bit thing. Are you running i386 or amd64?

    Try
    $ pkg_libchk -r gmake-3.81_4

    Make sure you use the actual version of gmake you have installed on that. A longer command that does it automatically would be
    $ pkg_libchk -r `pkg_info -Ix gmake | cut -f1 -d' '`
     
  3. hedgehog

    hedgehog New Member

    Messages:
    191
    Likes Received:
    0
    Greetings. I'm running amd64, but /etc/libmap32.conf is parsed by ld-elf.so while building www/webkit-gtk2 (changes made in /etc/libmap.conf are not in effect in this case)

    gmake is rebuilt few times today and it's up to date (according to ports). I had no problems building stuff from ports since summer and I think that it's not related to gmake:
    Code:
    $ pkg_info -xI gmake
    gmake-3.81_4        GNU version of 'make' utility
    $ pkg_libchk -R gmake-3.81_4
    reports no issues either. trying to run it with -a key

    PS: found a few missing libcrypt dependencies, nothing related to gettext
     
  4. hedgehog

    hedgehog New Member

    Messages:
    191
    Likes Received:
    0
    I have an outdated x86 world in /compat/i386 for wine. Looks like www/webkit-gtk2 is configured to use this path:

    Code:
    [/usr/obj/usr/ports/www/webkit-gtk2/work/webkit-1.2.5] $ grep compat *
    GNUmakefile:BISON = /compat/i386/usr/local/bin/bison
    GNUmakefile:GLIB_GENMARSHAL = /compat/i386/usr/local/bin/glib-genmarshal
    GNUmakefile:GLIB_MKENUMS = /compat/i386/usr/local/bin/glib-mkenums
    GNUmakefile:GPERF = /compat/i386/usr/local/bin/gperf
    GNUmakefile:PERL = /compat/i386/usr/local/bin/perl
    GNUmakefile:PKG_CONFIG = /compat/i386/usr/local/bin/pkg-config
    aclocal.m4:dnl while keeping a definition of mkdir_p for backward compatibility.
    aclocal.m4:[# Always define AMTAR for backward compatibility.
    bison_out.txt:/libexec/ld-elf.so.1: /usr/local/lib/compat/pkg/libintl.so.8: unsupported file layout
    config.log:PATH: /compat/i386/usr/local/bin
    config.log:configure:3042: checking for a BSD-compatible install
    config.log:configure:5567: found /compat/i386/usr/local/bin/pkg-config
    config.log:configure:5580: result: /compat/i386/usr/local/bin/pkg-config
    config.log:configure:5612: found /compat/i386/usr/local/bin/perl
    config.log:configure:5624: result: /compat/i386/usr/local/bin/perl
    config.log:configure:5656: found /compat/i386/usr/local/bin/bison
    config.log:configure:5668: result: /compat/i386/usr/local/bin/bison
    config.log:configure:7555: checking for BSD- or MS-compatible name lister (nm)
    config.log:configure:17092: found /compat/i386/usr/local/bin/gperf
    config.log:configure:17104: result: /compat/i386/usr/local/bin/gperf
    config.log:configure:17717: found /compat/i386/usr/local/bin/glib-genmarshal
    config.log:configure:17729: result: /compat/i386/usr/local/bin/glib-genmarshal
    config.log:configure:17757: found /compat/i386/usr/local/bin/glib-mkenums
    config.log:configure:17769: result: /compat/i386/usr/local/bin/glib-mkenums
    config.log:ac_cv_path_BISON=/compat/i386/usr/local/bin/bison
    config.log:ac_cv_path_GLIB_GENMARSHAL=/compat/i386/usr/local/bin/glib-genmarshal
    config.log:ac_cv_path_GLIB_MKENUMS=/compat/i386/usr/local/bin/glib-mkenums
    config.log:ac_cv_path_GPERF=/compat/i386/usr/local/bin/gperf
    config.log:ac_cv_path_PERL=/compat/i386/usr/local/bin/perl
    config.log:ac_cv_path_PKG_CONFIG=/compat/i386/usr/local/bin/pkg-config
    UPD--
    I've updated portstree this morning and noticed there is another autotools instructions, which I have followed:
    Code:
    20101208:
      AFFECTS: autotools
      AUTHOR: autotools@FreeBSD.org
    
      Another stage in the autotools cleanup that reduces tree churn whilst
      updating components, a number of ports have now moved to non-versioned
      locations since there is now only the concept of legacy and current
      versions.
    
      # portmaster -o devel/autoconf devel/autoconf268
      # portmaster -o devel/automake devel/automake111
      # portmaster -o devel/libtool devel/libtool22
      # portmaster -o devel/libltdl devel/libltdl22
    Once done with that, I launched # make clean and it's compiling without errors right now.
     
  5. hedgehog

    hedgehog New Member

    Messages:
    191
    Likes Received:
    0
    new issue :(
    Code:
    In file included from ./JavaScriptCore/wtf/Assertions.h:45,
                     from JavaScriptCore/API/tests/minidom.c:33:
    ./JavaScriptCore/wtf/Platform.h:778:11: warning: missing terminating ' character
      CC     WebKitTools/GtkLauncher/Programs_GtkLauncher-main.o
      CXX    WebKitTools/DumpRenderTree/Programs_DumpRenderTree-AccessibilityController.o
      CXX    WebKitTools/DumpRenderTree/Programs_DumpRenderTree-AccessibilityUIElement.o
      CXX    WebKitTools/DumpRenderTree/Programs_DumpRenderTree-GCController.o
      CXX    WebKitTools/DumpRenderTree/Programs_DumpRenderTree-LayoutTestController.o
      CXX    WebKitTools/DumpRenderTree/Programs_DumpRenderTree-WorkQueue.o
      CXX    WebKitTools/DumpRenderTree/gtk/Programs_DumpRenderTree-AccessibilityControllerGtk.o
      CXX    WebKitTools/DumpRenderTree/gtk/Programs_DumpRenderTree-AccessibilityUIElementGtk.o
      CXX    WebKitTools/DumpRenderTree/gtk/Programs_DumpRenderTree-DumpRenderTree.o
      CXX    WebKitTools/DumpRenderTree/gtk/Programs_DumpRenderTree-EventSender.o
      CXX    WebKitTools/DumpRenderTree/gtk/Programs_DumpRenderTree-GCControllerGtk.o
      CXX    WebKitTools/DumpRenderTree/gtk/Programs_DumpRenderTree-LayoutTestControllerGtk.o
      CXX    WebKitTools/DumpRenderTree/gtk/Programs_DumpRenderTree-WorkQueueItemGtk.o
      CC     WebKit/gtk/tests/Programs_unittests_testhttpbackend-testhttpbackend.o
      GEN    JSCore-1.0.typelib
    ./autotools/install-sh -c -d ./.deps/DerivedSources
      CXXLD  libJavaScriptCore.la
    Error at line 5, character 1: Unsupported version '1.2'
    error parsing file JSCore-1.0.gir: Unsupported version '1.2'
    gmake[1]: *** [JSCore-1.0.typelib] Ошибка 1
    gmake[1]: *** Ожидание завершения заданий...
    gmake[1]: Leaving directory `/usr/obj/usr/ports/www/webkit-gtk2/work/webkit-1.2.5'
    gmake: *** [all] Ошибка 2
    *** Error code 1
    
    Stop in /usr/ports/www/webkit-gtk2.
    *** Error code 1
    
    Stop in /usr/ports/www/webkit-gtk2.
     
  6. hedgehog

    hedgehog New Member

    Messages:
    191
    Likes Received:
    0
    solved after updating all installed ports