1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Postfix and hostname

Discussion in 'Web and Network Services' started by xy16644, Jul 29, 2009.

  1. xy16644

    xy16644 Member

    Messages:
    846
    Thanks Received:
    9
    Currently I have a server called:

    alpha.mydomain.com

    but my MX record is:

    mail.mydomain.com (reverse DNS is setup for this domain too)

    When I send email it appears to come from alpha.mydomain.com in the message headers. I dont want to change the hostname of the server so how can I force Postfix to send all out going mail as coming from mail.mydomain.com?

    I run the latest version of Postfix, Procmail and Spamassasin all on the same box running FreeBSD 7.2.

    Does the hostname of the server have to match your MX record or can it be different? If you can change it then where? I cant seem to find it...:e
     
  2. dennylin93

    dennylin93 New Member

    Messages:
    784
    Thanks Received:
    104
    Usually $myhostname is set as the output of $ hostname. What you want to change should be $myorigin in /usr/local/etc/postfix/main.cf. Another option is masquerading, but I believe it's usually used for mail gateways.

    I have a mail server called mail.example.com, but I want the mail to appear from example.com:
    Code:
    $myhostname = mail.example.com
    $mydomain = example.com
    $myorigin = $mydomain
    


    I'm using this configuration, but there's something weird with Mutt. It still sends mail that appears from mail.example.com. All other clients are OK though.

    Take a look at Postfix Configuration Parameters and Postfix Address Rewriting.
     
    xy16644 thanks for this.
  3. xy16644

    xy16644 Member

    Messages:
    846
    Thanks Received:
    9
    Changing:

    Code:
    myorigin = $mydomain
    


    to

    Code:
    myorigin = mail.mydomain.com
    


    didn't change anything for me. But changing:

    Code:
    myhostname = mail.mydomain.com
    


    seemed to do the trick!

    If I look in the message headers, the before snaphot looks like this:

    Code:
    
    Received: from alpha.mydomain.com ([xxx.xxx.xxx.xx]) by col0-mc4-f10.Col0.hotmail.com with Microsoft SMTPSVC(6.0.3790.3959);
    


    after making the change:
    Code:
    Received: from mail.mydomain.com ([xxx.xxx.xxx.xx]) by col0-mc2-f27.Col0.hotmail.com with Microsoft SMTPSVC(6.0.3790.3959);
    

    Thanks very much for your help!