1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PKGNG - portmaster disabled problem

Discussion in 'Installation and Maintenance of Ports or Packages' started by pphalen, Oct 30, 2012.

  1. pphalen

    pphalen New Member

    Messages:
    11
    Likes Received:
    0
    On two servers, I followed the instructions for updating to pkgng, with portmaster:
    Code:
    # portsnap fetch update
    # make -C /usr/ports/ports-mgmt/portmaster config clean build deinstall install
    # echo "WITH_PKGNG=yes" >> /etc/make.conf
    # pkg2ng
    
    Now, one machine updates with portmaster without complaint, but the other says:
    Code:
    "Package installation support cannot be used with pkgng yet, it will be disabled."
    
    I reinstalled portmaster again, but that didn't help. Suggestions?

    FreeBSD 9.0-RELEASE
     
  2. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,362
    Likes Received:
    0
  3. pphalen

    pphalen New Member

    Messages:
    11
    Likes Received:
    0
    Yes, I've already tried twice
    # make -C /usr/ports/ports-mgmt/portmaster config clean build deinstall install

    and confirmed PKGNGPATCH box was checked. Same problem. And then attempting to run pkg2ng again complains of corrupted formats, since it uses pkg_info(1). So I'm still stuck.
     
  4. break19

    break19 New Member

    Messages:
    127
    Likes Received:
    0
    "Package installation support cannot be used with pkgng yet, it will be disabled." Means just what it says.. You cannot use portmaster to install -packages- only ports.
     
  5. pphalen

    pphalen New Member

    Messages:
    11
    Likes Received:
    0
    Thanks, but as I mentioned, one (identically configured) other machine doesn't issue that warning. So still a bit of a puzzle...
     
  6. KdeBruin

    KdeBruin New Member

    Messages:
    38
    Likes Received:
    0
    Did you by any change install any packages on the machine with the warning?
     
  7. pphalen

    pphalen New Member

    Messages:
    11
    Likes Received:
    0
    Portmaster installed ports, but I haven't manually installed any packages using the 'pkg' command. Is that what you mean?
     
  8. tankist02

    tankist02 New Member

    Messages:
    97
    Likes Received:
    0
    I also have the same problem with portmaster and pkgng.
     
  9. dave

    dave New Member

    Messages:
    342
    Likes Received:
    0
    Same
     
  10. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,609
    Likes Received:
    7
    The portmaster warning about packages should only come up if you're running it with the -P or -PP flag (or equivalent setting in /usr/local/etc/portmaster.rc, like using only packages for build dependencies, etc.).
     
  11. kpa

    kpa Member

    Messages:
    3,991
    Likes Received:
    3
    There's no reason to use the package options of ports-mgmt/portmaster with PKGNG, use pkg install etc. directly.
     
  12. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,609
    Likes Received:
    7
    Installing ports with portmaster while using binary packages for build-only dependencies (removing them right after installation) is a very nice thing to have. That's a regular option in portmaster.rc, and I hope to see it working again soon.
     
  13. ObiektywNy

    ObiektywNy New Member

    Messages:
    54
    Likes Received:
    0
    I need some clarification. I used portmaster, and I am on a fresh 9.1-RELEASE, should I now only use pkg install to install the ports or I can still use a string as # portmaster /lang/php5 or is installation with # cd /usr/ports/lang/php5/ && make install clean also fine? I am not sure with installation way I can use and which I should not mix.
     
  14. dave

    dave New Member

    Messages:
    342
    Likes Received:
    0
    Get clear on the difference between packages and ports: http://www.freebsd.org/doc/en/books/handbook/ports.html

    I suggest you use ports, and portmaster is a great utility for managing ports. If you don't have it installed already, # cd /usr/ports/ports-mgmt/portmaster && make install clean. Also, drop the leading slash from your portmaster command: # portmaster lang/php5.

    And make sure you read up on the options for portmaster: # man portmaster
     
  15. Bucky

    Bucky New Member

    Messages:
    4
    Likes Received:
    0
    Fresh install of FBSD 9.1

    For a fresh install of FreeBSD 9.1 (since July 2013 and probably earlier), do NOT invoke the pkg command. Do the fresh install like this:

    Fresh install per usual, login/password, do minor housekeeping, then in this order:
    1. Add
      Code:
      WITH_PKGNG=yes
      to /etc/make.conf
    2. portsnap fetch extract
    3. cd /usr/ports/ports-mgmt/pkg ( make install clean)
    4. cd /usr/ports/ports-mgmt/portmaster ( make install clean)
    then use pkg version to show installed ports and portmaster -L to confirm the same thing.

    If you simply type pkg instead of installing pkg from the ports collection as described above, it will install an earlier version of pkg which doesn't play nice with portmaster. On a fresh install you do NOT need to run pkg2ng, since there is no database to convert at that point.

    I confirmed this behavior on a Virtualbox install a few minutes ago (using x32 architecture, but it is certainly also true for the x64 platform.)

    Cheers!

    PS - this may be needed for the upcoming 9.2 release as well, so do the ports collection install and avoid a headache.
     
  16. morbit

    morbit New Member

    Messages:
    215
    Likes Received:
    0
    This somehow bite me after just reading announcement and finally taking the plunge.

    http://lists.freebsd.org/pipermail/freebsd-pkg/2013-October/000107.html

    Previously, I was waiting for packages to appear exactly because of this portmaster's feature.
     
  17. gushi

    gushi New Member

    Messages:
    1
    Likes Received:
    0
    It's been a year. Apparently no change?
     
  18. dave

    dave New Member

    Messages:
    342
    Likes Received:
    0