1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[PC-BSD] snapshot update

Discussion in 'Installation and Maintenance of Ports or Packages' started by grimx, Mar 30, 2010.

  1. grimx

    grimx New Member

    Messages:
    25
    Thanks Received:
    0
    i'm using pcbsd 8.0
    still waiting for the admin at the pcbsd forums to allow my post , 12 hrs and counting.

    ok, when i run portsnap update, which i've run three times now and get the same results.

    i get this everytime:
    Code:
    etching snapshot tag from portsnap1.FreeBSD.org... done.
    Fetching snapshot metadata... done.
    Fetching snapshot generated at Mon Mar 29 17:16:34 MST 2010:
    7b7e427b31169aac241a03f333bc9e878e2af23cd25958100% of   61 MB  316 kBps 00m00s
    Extracting snapshot... done.
    Verifying snapshot integrity... gunzip: invalid compressed data--crc error
    gunzip: snap/99664719f5c02553a12e8ea31c061deb079e08f1fade0d639b43ab36f9094f6b.gz: uncompress failed
    snapshot corrupt.
    
     
  2. grimx

    grimx New Member

    Messages:
    25
    Thanks Received:
    0
    the reason i'm running portsnap is i'm hoping to fix this,
    when tring pkg_add codeblocks.
    Code:
    pkg_add -r codeblocks
    Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8.0-release/Latest/codeblocks.tbz... Done.                                                       
    Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8.0-release/All/g                                Done.                                           
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'expat-2.0.1', but 'expat-2.0.1_1' is installed                                                                     
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'hicolor-icon-theme-0.10_2', but 'hicolor-icon-theme-0.12' is installed                                             
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'python26-2.6.2_3', but 'python26-2.6.4' is installed                                                               
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'xcb-proto-1.5', but 'xcb-proto-1.6' is installed                                                                   
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'png-1.2.40', but 'png-1.2.42' is installed                                                                         
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'jpeg-7', but 'jpeg-8' is installed
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'tiff-3.9.1', but 'tiff-3.9.2_1' is installed                                                                       
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'jasper-1.900.1_8', but 'jasper-1.900.1_9' is installed                                                                                
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'freetype2-2.3.9_1', but 'freetype2-2.3.11' is installed                                                            
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'fontconfig-2.6.0,1', but 'fontconfig-2.8.0,1' is installed                                                         
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'pcre-7.9', but 'pcre-8.00' is installed                                                                                               
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'libpthread-stubs-0.1', but 'libpthread-stubs-0.3_3' is installed                                                   
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'libxcb-1.4', but 'libxcb-1.5' is installed                                                                                            
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'libXft-2.1.13', but 'libXft-2.1.14' is installed                                                                                      
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'xcb-util-0.3.6', but 'xcb-util-0.3.6_1' is installed                                                               
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'libiconv-1.13.1', but 'libiconv-1.13.1_1' is installed                                                                                
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'libxml2-2.7.5', but 'libxml2-2.7.6_1' is installed                                                                                    
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'glib-2.20.5', but 'glib-2.22.4' is installed                                                                                          
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'gio-fam-backend-2.20.5', but 'gio-fam-backend-2.22.4' is installed                                                                    
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'pango-1.24.5', but 'pango-1.26.2' is installed                                                                                        
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'shared-mime-info-0.60_1', but 'shared-mime-info-0.70' is installed                                                                    
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'atk-1.26.0', but 'atk-1.28.0' is installed                                                                                            
    pkg_add: warning: package 'gnome-icon-theme-2.26.0_2' requires 'gtk-2.16.6', but 'gtk-2.18.6_1' is installed                                                                                          
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'dri2proto-2.0', but 'dri2proto-2.1' is installed                                                                                              
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'expat-2.0.1', but 'expat-2.0.1_1' is installed                                                                                                
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'hicolor-icon-theme-0.10_2', but 'hicolor-icon-theme-0.12' is installed                                                                        
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'python26-2.6.2_3', but 'python26-2.6.4' is installed                                                                                          
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'xcb-proto-1.5', but 'xcb-proto-1.6' is installed                                                                                              
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'png-1.2.40', but 'png-1.2.42' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'jpeg-7', but 'jpeg-8' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'tiff-3.9.1', but 'tiff-3.9.2_1' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'jasper-1.900.1_8', but 'jasper-1.900.1_9' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'freetype2-2.3.9_1', but 'freetype2-2.3.11' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'fontconfig-2.6.0,1', but 'fontconfig-2.8.0,1' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'pcre-7.9', but 'pcre-8.00' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'libpthread-stubs-0.1', but 'libpthread-stubs-0.3_3' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'libxcb-1.4', but 'libxcb-1.5' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'libXft-2.1.13', but 'libXft-2.1.14' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'xcb-util-0.3.6', but 'xcb-util-0.3.6_1' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'libiconv-1.13.1', but 'libiconv-1.13.1_1' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'libxml2-2.7.5', but 'libxml2-2.7.6_1' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'dbus-1.2.4.6_1', but 'dbus-1.2.16_1' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'glib-2.20.5', but 'glib-2.22.4' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'gio-fam-backend-2.20.5', but 'gio-fam-backend-2.22.4' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'gstreamer-0.10.24', but 'gstreamer-0.10.25' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'gstreamer-plugins-0.10.24,3', but 'gstreamer-plugins-0.10.25,3' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'shared-mime-info-0.60_1', but 'shared-mime-info-0.70' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'pango-1.24.5', but 'pango-1.26.2' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'dbus-glib-0.82', but 'dbus-glib-0.84' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'policykit-0.9_5', but 'policykit-0.9_6' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'atk-1.26.0', but 'atk-1.28.0' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'gtk-2.16.6', but 'gtk-2.18.6_1' is installed
    pkg_add: warning: package 'codeblocks-8.02_3' requires 'gconf2-2.26.2_1', but 'gconf2-2.28.0_1' is installed
    root@pcbsd-2053# whereis codeblocks
    codeblocks: /usr/local/bin/codeblocks /usr/local/man/man1/codeblocks.1.gz /usr/ports/devel/codeblocks
    

    hoping to get a newer version of codeblocks that will use the packages above.
     
  3. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,515
    Thanks Received:
    2,351
    Codeblocks is installing but some of it's dependencies have different versions than the ones you have installed.
     
  4. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,721
    Thanks Received:
    2,137
    And since all required dependency versions are newer than codeblocks requires, you should generally not have a problem.