1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No JDK 1.6 for FreeBSD-8 (yet)

Discussion in 'Installation and Maintenance of Ports or Packages' started by mrstolpe, Aug 26, 2009.

  1. mrstolpe

    mrstolpe New Member

    Messages:
    9
    Likes Received:
    0
    I am currently testing:

    Code:
    FreeBSD 8.0-BETA3 FreeBSD 8.0-BETA3 #0: Sat Aug 22 02:00:45 UTC 2009     [email]root@mason.cse.buffalo.edu[/email]:/usr/obj/usr/src/sys/GENERIC  amd64
    and jdk does not build properly:

    Code:
    /usr/local/diablo-jdk1.6.0/bin/java -version
    Error occurred during initialization of VM
    Unable to load ZIP library: /usr/local/diablo-jdk1.6.0/jre/lib/amd64/libzip.so
    I guess there will appear some "8"-versions on this site:

    http://www.freebsdfoundation.org/downloads/java.shtml

    that might solve the problem?
     
  2. mrstolpe

    mrstolpe New Member

    Messages:
    9
    Likes Received:
    0
    diablo-jdk-1.6.0.07.02_5

    is installed and the "unloadable" file exists but maybe the "7"-version does not work on a "8"-system?
     
  3. ale

    ale New Member

    Messages:
    1,059
    Likes Received:
    0
  4. mrstolpe

    mrstolpe New Member

    Messages:
    9
    Likes Received:
    0
    /usr/local/diablo-jdk1.6.0/bin/java -version
    java version "1.6.0_07"
    Diablo Java(TM) SE Runtime Environment (build 1.6.0_07-b02)
    Diablo Java HotSpot(TM) 64-Bit Server VM (build 10.0-b23, mixed mode)

    I tried but as it seems not hard enough. Odd solution but it works so far ;)
     
  5. ale

    ale New Member

    Messages:
    1,059
    Likes Received:
    0
    If you want to get rid of the setting, you can use diablo-jdk to bootstrap the build of java/jdk16. Once installed you can remove diablo-jdk and restore the configuration.