1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mp3 support for amarok

Discussion in 'Multimedia' started by estellnb, Feb 15, 2009.

  1. estellnb

    estellnb New Member

    Messages:
    38
    Thanks Received:
    0
    Though amarok can play flac files its xine plugin refuses to play mp3s.
    There are no other output plugins available for amarok.
    Installing any of the following additional xine addons does not help either:
    totem-xine
    toxine
    kdemultimedia-xine_artsplugin
    npapi-xine

    > gibts gstreamer-plugins-xine
    Port: multimedia/gstreamer-plugins-xine
    Moved:
    Date: 2005-05-31
    Reason: obsolete, use gstreamer-ffmpeg instead

    gstreamer-ffmpeg-0.10.4_1 is installed
    but xine can not use it
     
  2. hydra

    hydra New Member

    Messages:
    272
    Thanks Received:
    24
  3. estellnb

    estellnb New Member

    Messages:
    38
    Thanks Received:
    0
    Sorry that was a mistake. I could not delete the second thread.
     
  4. lme@

    lme@ Administrator Staff Member Administrator Moderator Developer

    Messages:
    640
    Thanks Received:
    208
    I just deleted the other thread.
     
  5. Djn

    Djn New Member

    Messages:
    392
    Thanks Received:
    62
    Try installing multimedia/libxine from the port. It depends on libmad, which is an mp3 decoder, so it should already be able to play them; I really have no idea why you can't.
     
  6. estellnb

    estellnb New Member

    Messages:
    38
    Thanks Received:
    0
    libxine & libmad are already installed.
    Perhaps a configuration issue.

    > pkgs libxine
    libxine-1.1.14
    > pkgs libmad
    libmad-0.15.1b_2
     
  7. Djn

    Djn New Member

    Messages:
    392
    Thanks Received:
    62
    And just to verify, you have xineplug_decode_mad.so in /usr/local/lib/xine/1.14/ ?

    I notice I've got libxine 1.21 locally, but it's not like mp3 support should be a bleeding-edge feature ...
     
  8. estellnb

    estellnb New Member

    Messages:
    38
    Thanks Received:
    0
    > find /usr/local/lib/xine/ | grep xineplug_decode_mad.so
    /usr/local/lib/xine/plugins/1.23/xineplug_decode_mad.so
     
  9. nal

    nal New Member

    Messages:
    13
    Thanks Received:
    3
    Whether the problem is solved?
     
  10. estellnb

    estellnb New Member

    Messages:
    38
    Thanks Received:
    0
    No, not yet.
     
  11. nal

    nal New Member

    Messages:
    13
    Thanks Received:
    3
    Somebody has found a way to fix this bug?
     
  12. phoenix

    phoenix Moderator Staff Member Moderator

    Messages:
    3,446
    Thanks Received:
    769
    First, is this for Amarok 1.x (KDE3) or Amarok 2.x (KDE4)?

    For Amarok 1.x:
    Do you have audio/akode installed? Akode provides the MP3 (among others) playback functions for KDE3 apps.

    For Amarok 2.x, it should just work automatically.
     
  13. nal

    nal New Member

    Messages:
    13
    Thanks Received:
    3
    Amarok 2.x (KDE4)
    I had installed audio/amarok-kde4 and ran it. I opened any the MP3 files, but they did not playback.
    Only formats Wav, Flac and Ogg was played.
     
  14. phoenix

    phoenix Moderator Staff Member Moderator

    Messages:
    3,446
    Thanks Received:
    769
    Hrm, how bizarre.

    I installed Amarok 2.0 (upgraded to 2.1 recently) on my KDE 4.x box (originally 4.1, then 4.2, now 4.3) and could play MP3 files from the get go, through all the in-place upgrades.

    What version of the following do you have installed:
    audio/amarok-kde4
    multimedia/phonon
    multimedia/phonon-xine
    multimedia/qt4-phonon
    x11/kdelibs4

    And, do you have any gstreamer-related ports installed? (gstreamer*, gstreamer-plugins*, qt4-phonon-gst*)?
     
  15. nal

    nal New Member

    Messages:
    13
    Thanks Received:
    3
    Code:
    # pkg_info | grep phonon
    phonon-xine-4.3.1_3 Phonon xine backend
    qt4-phonon-4.5.2    Qt4 multimedia framework
    qt4-phonon-gst-4.5.2 Qt4 multimedia framework, gstreamer backend
    # pkg_info |grep amarok
    amarok-2.1.1_1      Media player for KDE4
    # pkg_info | grep kdelib
    kdelibs-4.3.1_1     Base set of libraries needed by KDE programs
    kdelibs-experimental-4.3.1 Experimantal set of libraries needed by KDE programs
    # pkg_info | grep gstreamer
    gstreamer-0.10.24   Development framework for creating media applications
    gstreamer-plugins-0.10.24,3 GStreamer written collection of plugins handling several me
    qt4-phonon-gst-4.5.2 Qt4 multimedia framework, gstreamer backend
     
  16. phoenix

    phoenix Moderator Staff Member Moderator

    Messages:
    3,446
    Thanks Received:
    769
    You've got the same versions installed as I do.

    Can you open a shell, and run amarok from there, to see if there are any errors messages being output?
     
  17. estellnb

    estellnb New Member

    Messages:
    38
    Thanks Received:
    0
  18. estellnb

    estellnb New Member

    Messages:
    38
    Thanks Received:
    0
    Code:
    > pkg_info | egrep "phonon|amarok|kdelib"
    
    amarok-1.4.10       Media player for KDE
    kdelibs-3.5.10      Base set of libraries needed by KDE programs


    Code:
    > pkgs gstreamer
    
    gstreamer-0.10.20
    gstreamer-ffmpeg-0.10.4_1
    gstreamer-plugins-0.10.20_2,3
    gstreamer-plugins-a52dec-0.10.9_3,3
    gstreamer-plugins-aalib-0.10.10_3,3
    gstreamer-plugins-annodex-0.10.10_2,3
    gstreamer-plugins-bad-0.10.8_1,3
    gstreamer-plugins-buzztard-0.2.0_1
    gstreamer-plugins-cairo-0.10.10_3,3
    gstreamer-plugins-cdaudio-0.10.8_3,3
    gstreamer-plugins-cdparanoia-0.10.20_1,3
    gstreamer-plugins-core-0.10_10
    gstreamer-plugins-dts-0.10.8_3,3
    gstreamer-plugins-dv-0.10.10_3,3
    gstreamer-plugins-dvd-0.10.9_3,3
    gstreamer-plugins-esound-0.10.10_3,3
    gstreamer-plugins-faac-0.10.8_3,3
    gstreamer-plugins-faad-0.10.8_3,3
    gstreamer-plugins-flac-0.10.10_4,3
    gstreamer-plugins-fluendo-mpegdemux-0.10.15_1
    gstreamer-plugins-gconf-0.10.10_4,3
    gstreamer-plugins-gdk_pixbuf-0.10.10_3,3
    gstreamer-plugins-gio-0.10.20_2,3
    gstreamer-plugins-gnomevfs-0.10.20_1,3
    gstreamer-plugins-gnonlin-0.10.9_1
    gstreamer-plugins-good-0.10.10,3
    gstreamer-plugins-gsm-0.10.8_3,3
    gstreamer-plugins-hal-0.10.10_4,3
    gstreamer-plugins-ivorbis-0.10.8_3,3
    gstreamer-plugins-jack-0.10.8_3,3
    gstreamer-plugins-jpeg-0.10.10_3,3
    gstreamer-plugins-ladspa-0.10.10_3,3
    gstreamer-plugins-lame-0.10.9_3,3
    gstreamer-plugins-libcaca-0.10.10_3,3
    gstreamer-plugins-libmms-0.10.8_3,3
    gstreamer-plugins-libpng-0.10.10_3,3
    gstreamer-plugins-libvisual-0.10.20_1,3
    gstreamer-plugins-mad-0.10.9_3,3
    gstreamer-plugins-moodbar-0.1.2_3
    gstreamer-plugins-mp3-0.10.0_1
    gstreamer-plugins-mpeg2dec-0.10.9_3,3
    gstreamer-plugins-mpeg2enc-0.10.8_3,3
    gstreamer-plugins-musepack-0.10.8_3,3
    gstreamer-plugins-musicbrainz-0.10.8_3,3
    gstreamer-plugins-nas-0.10.8_3,3
    gstreamer-plugins-ogg-0.10.20_1,3
    gstreamer-plugins-pango-0.10.20_1,3
    gstreamer-plugins-pulse-0.9.7_1
    gstreamer-plugins-sdl-0.10.8_3,3
    gstreamer-plugins-sidplay-0.10.9_3,3
    gstreamer-plugins-sndfile-0.10.8_2,3
    gstreamer-plugins-soundtouch-0.10.8_3,3
    gstreamer-plugins-soup-0.10.10_3,3
    gstreamer-plugins-speex-0.10.10_3,3
    gstreamer-plugins-taglib-0.10.10_4,3
    gstreamer-plugins-theora-0.10.20_1,3
    gstreamer-plugins-ugly-0.10.9_1,3
    gstreamer-plugins-vorbis-0.10.20_1,3
    gstreamer-plugins-wavpack-0.10.10_3,3
    gstreamer-plugins-xvid-0.10.8_3,3
    py25-gstreamer-0.10.12
     
  19. nal

    nal New Member

    Messages:
    13
    Thanks Received:
    3
    I have found the reason: https://bugzilla.redhat.com/show_bug.cgi?id=493759#c22

    my locale is
    Code:
    % locale
    LANG=ru_RU.KOI8-R
    LC_CTYPE="ru_RU.KOI8-R"
    LC_COLLATE="ru_RU.KOI8-R"
    LC_TIME="ru_RU.KOI8-R"
    LC_NUMERIC="ru_RU.KOI8-R"
    LC_MONETARY="ru_RU.KOI8-R"
    LC_MESSAGES="ru_RU.KOI8-R"
    LC_ALL=
     
  20. phoenix

    phoenix Moderator Staff Member Moderator

    Messages:
    3,446
    Thanks Received:
    769
    Just to close this up for the archives ...

    Changing your locale settings fixed the issue? Or renaming the files? Or both? Or something else?
     
  21. nal

    nal New Member

    Messages:
    13
    Thanks Received:
    3
    any way fixed this bug.
    I have renamed the files - Amarok have started playback.
     
  22. raul_comodoro

    raul_comodoro New Member

    Messages:
    19
    Thanks Received:
    0
    Amarok runs perfectly in PC-BSD 8.2, and it was OK in Free BSD in previous releases

    I remember Amarok running OK in FreeBSD, at least in my system, previously to BSD 8.0.

    Now, using FreeBSD 8.0 there is the problem, long commented in these posts, that mp3 files cannot be played.

    I wonder if some people experienced enough could say what are the libraries and other files that PC-BSD 8.2 uses related with Amarok, as a way to make a comparing with FreeBSD to look for a solution.

    I am talking about FreeBSD with KDE 3.5 and Amarok 1.4, PC-BSD is working with KDE 4 and Amarok 2, but for instance may be somebody could help anyway.

    I let the code here, of packages installed in PC-BSD.

    Code:
    alsa-lib-1.0.23
    amarok-2.3.2
    amspsfnt-1.0_5
    appres-1.0.2
    atk-1.32.0
    attica-0.2.0,1
    autoconf-2.68
    autoconf-wrapper-20101119
    automake-1.11.1
    automake-wrapper-20101119
    automoc4-0.9.88_1
    avahi-app-0.6.28
    bdftopcf-1.0.2
    bigreqsproto-1.1.0
    boehm-gc-7.1
    boost-jam-1.43.0
    boost-libs-1.43.0_1
    boost-python-libs-1.43.0
    bsdstats-5.5_1
    bwn-firmware-kmod-0.1.0
    cagibi-0.1.1
    cairo-1.10.0_3,1
    cdparanoia-3.9.8_9
    cdrdao-1.2.3_1
    cdrtools-3.00_1
    compat5x-i386-5.4.0.8.1_1
    compat6x-i386-6.4.604000.200810_3
    compat7x-i386-7.3.703000.201008_1
    compositeproto-0.4.1
    consolekit-0.4.3
    db41-4.1.25_4
    db42-4.2.52_5
    db46-4.6.21.4
    dbus-1.4.0
    dbus-glib-0.88
    dbus-qt3-0.70_5
    dconf-0.5.1_3
    dvd+rw-tools-7.1
    dvipsk-tetex-5.95a_5
    esound-0.2.41
    espeak-1.44.05
    evieext-1.1.0
    exiv2-0.20,1
    expat-2.0.1_1
    faad2-2.7_3,1
    ffmpeg-0.6.1_2,1
    fftw3-3.2.2_1
    fftw3-float-3.2.2_2
    fixesproto-4.1.1
    flac-1.2.1_2
    flex-2.5.35_4
    flite-1.3
    gamin-0.1.10_4
    gawk-3.1.7_2
    gccmakedep-1.0.2
    gconf2-2.32.0_2
    gd-2.0.35_7,1
    gdbm-1.8.3_3
    gdk-pixbuf-2.22.1
    ggz-client-libs-0.0.14.1_2
    gio-fam-backend-2.26.1
    gle-3.1.0_2
    glib-1.2.10_13
    glib-2.26.1_1
    gmake-3.81_4
    gmm++-4.1
    gmp-5.0.1
    gnomehier-2.3_12
    gnupg-2.0.16_2
    gnutls-2.8.6_2
    gob2-2.0.17
    gpac-libgpac-0.4.5_4,1
    gperf-3.0.3
    gpgme-1.3.0
    gpsd-2.95
    graphviz-2.26.3_3
    gsl-1.14
    gstreamer-0.10.31
    gstreamer-ffmpeg-0.10.11_1
    gstreamer-plugins-0.10.31,3
    gstreamer-plugins-a52dec-0.10.16,3
    gstreamer-plugins-bad-0.10.20,3
    gstreamer-plugins-core-0.10_12
    gstreamer-plugins-dts-0.10.20,3
    gstreamer-plugins-dvd-0.10.16,3
    gstreamer-plugins-good-0.10.26,3
    gstreamer-plugins-libpng-0.10.26,3
    gstreamer-plugins-mad-0.10.16,3
    gstreamer-plugins-mp3-0.10.0_1
    gstreamer-plugins-ogg-0.10.31,3
    gstreamer-plugins-pango-0.10.31,3
    gstreamer-plugins-theora-0.10.31,3
    gstreamer-plugins-ugly-0.10.16,3
    gstreamer-plugins-vorbis-0.10.31,3
    gstreamer-plugins-xvid-0.10.20,3
    gtk-1.2.10_22
    gtk-2.22.1_1
    gtk-engines2-2.20.1_1
    gtk-qt4-engine-1.1_5
    gtk2-qtcurve-theme-1.8.0
    gvfs-1.6.6
    ibus-1.3.8
    ibus-m17n-1.3.0
    ibus-qt-1.3.0
    ibus-table-1.3.0.20100621
    iceauth-1.0.3
    icoconvert-2.0_4
    icod-1.0
    icu-3.8.1_3
    ilmbase-1.0.1_1
    imake-1.0.3,1
    imlib-1.9.15_12
    inputproto-2.0
    intltool-0.41.1
    jackit-0.118.0_2
    jailme-0.1
    jasper-1.900.1_9
    jbig2dec-0.11
    jbigkit-1.6
    jpeg-8_3
    kaffeine-1.2.2
    kbproto-1.0.4
    kde4-4.5.4
    kdebase-3.5.10_7
    kdebase-4.5.4
    kdelibs-3.5.10_6
    kdelibs-4.5.4
    kdemultimedia-4.5.4
    kmplayer-kde4-0.11.2b,3
    lame-3.98.4
    lcms-1.19_1,1
    libFS-1.0.2
    libGL-7.4.4
    libGLU-7.4.4
    libICE-1.0.6,1
    libIDL-0.8.14_1
    libSM-1.1.1_3,1
    libX11-1.3.3_1,1
    libXScrnSaver-1.2.0
    libXTrap-1.0.0
    libXau-1.0.5
    libXaw-1.0.7,1
    libXcomposite-0.4.1,1
    libXcursor-1.1.10
    libXdamage-1.1.2
    libXdmcp-1.0.3
    libXevie-1.0.2
    libXext-1.1.1,1
    libXfixes-4.0.4
    libXfont-1.4.0,1
    libXfontcache-1.0.5
    libXft-2.1.14
    libXi-1.3,1
    libXinerama-1.1,1
    libXmu-1.0.5,1
    libXp-1.0.0,1
    libXpm-3.5.7
    libXrandr-1.3.0
    libXrender-0.9.5
    libXres-1.0.4
    libXt-1.0.7
    libXtst-1.1.0
    libXv-1.0.5,1
    libXvMC-1.0.5
    libXxf86dga-1.1.1
    libXxf86misc-1.0.2
    libXxf86vm-1.1.0
    liba52-0.7.4_2
    libao-1.0.0
    libart_lgpl-2.3.21,1
    libassuan-2.0.0
    libaudiofile-0.2.7
    libbonobo-2.32.0
    libbonoboui-2.24.4
    libcanberra-0.26
    libcddb-1.3.2_1
    libcdio-0.82_1
    libcheck-0.9.8
    libcroco-0.6.2_1
    libdaemon-0.14
    libdbusmenu-qt-0.6.4
    libdca-0.0.5
    libdmx-1.1.0
    libdrm-2.4.12_1
    libdvdcss-1.2.10_1
    libdvdread-4.1.4.r1219
    libexecinfo-1.1_3
    libexif-0.6.18_1
    libfame-0.9.1_2
    libffi-3.0.9
    libfontenc-1.0.5
    libfpx-1.2.0.12_1
    libgcal-0.9.5
    libgcrypt-1.4.6
    libgee-0.6.0
    libggz-0.0.14.1_7
    libglade2-2.6.4_3
    libglut-7.4.4
    libgnome-2.32.0
    libgnome-keyring-2.32.0
    libgnomecanvas-2.30.2
    libgnomesu-1.0.0_9
    libgnomeui-2.24.4
    libgpg-error-1.10
    libgphoto2-2.4.10.1
    libgpod-0.7.2_4
    libgsf-1.14.19
    libical-0.44
    libiconv-1.13.1_1
    libid3tag-0.15.1b
    libidn-1.16
    libijs-0.35_1
    libiodbc-3.52.7
    libkate-0.3.7_1
    libksba-1.0.8
    libktorrent-1.0.4
    liblastfm-0.3.0_1
    liblqr-1-0.4.1_2
    libltdl-2.2.10
    libmad-0.15.1b_2
    libmikmod-3.1.12
    libmimedir-0.5.1
    libmng-1.0.10_2
    libmodplug-0.8.8.1
    libmsn-4.1
    libmtp-1.0.3
    libmusicbrainz-2.1.5
    libnice-0.0.13_1
    libnotify-0.5.2
    libnova-0.13.0
    libofa-0.9.3_4
    libogg-1.2.1,4
    liboldX-1.0.1
    libotf-0.9.11
    libotr-3.2.0_3
    libpaper-1.1.24
    libpciaccess-0.12.0
    libproxy-0.2.3_1
    libpthread-stubs-0.3_3
    libqalculate-0.9.7_1
    librsvg2-2.32.1_1
    librtfcomp-1.1
    libsamplerate-0.1.7_1
    libsndfile-1.0.23
    libsoup-2.32.2
    libsoup-gnome-2.32.2
    libspectre-0.2.6
    libssh-0.4.6_1
    libtasn1-2.8
    libthai-0.1.5_4
    libtheora-1.1.1_2
    libtool-2.2.10
    libtunepimp-0.5.3_9,1
    libublio-20070103
    libungif-4.1.4_5
    libutempter-1.1.5_1
    libv4l-0.8.1
    libvdpau-0.4.1_1
    libvncserver-0.9.7_2
    libvolume_id-0.81.1
    libvorbis-1.3.2,3
    libvpx-0.9.5
    libwww-5.4.0_4
    libxcb-1.7
    libxine-1.1.19_1
    libxkbfile-1.0.6
    libxkbui-1.0.2_1
    libxklavier-5.0,1
    libxml2-2.7.8_1
    libxslt-1.1.26_2
    libzip-0.9.3
    lineakd-0.9_2
    linux-f10-atk-1.24.0
    linux-f10-cairo-1.8.0_1
    linux-f10-curl-7.19.6_1
    linux-f10-cyrus-sasl2-2.1.22_1
    linux-f10-dri-7.2_1
    linux-f10-expat-2.0.1
    linux-f10-flashplugin-10.1r102.65
    linux-f10-fontconfig-2.6.0
    linux-f10-gtk2-2.14.7_2
    linux-f10-jpeg-6b
    linux-f10-libGLU-7.2
    linux-f10-libssh2-0.18
    linux-f10-nspr-4.7.6
    linux-f10-nss-3.12.3.99.3_1
    linux-f10-openldap-2.4.12_1
    linux-f10-openssl-0.9.8g
    linux-f10-png-1.2.37_1
    linux-f10-sqlite3-3.5.9_1
    linux-f10-tiff-3.8.2
    linux-f10-xorg-libs-7.4_1
    linux_base-f10-10_3
    localedata-5.4
    loudmouth-1.4.3_3
    luit-1.0.5
    mDNSResponder-214.3.2_1
    makedepend-1.0.2,1
    marble-4.5.4
    meanwhile-1.0.2_2
    mesa-demos-7.4.4
    mp4v2-1.9.1
    mpage-2.5.6
    mpfr-3.0.0
    mplayer-1.0.r20101106
    musepack-2009.03.01_1
    mysql-client-5.1.53
    mysql-server-5.1.53
    nspluginwrapper-1.2.2_7
    nspr-4.8.6
    nss_mdns-0.10_2
    openjpeg-1.3_2
    openslp-1.2.1_3
    ortp-0.13.0_1
    p5-Locale-gettext-1.05_3
    p5-XML-LibXML-1.70,1
    p5-XML-NamespaceSupport-1.11
    p5-XML-Parser-2.40
    p5-XML-SAX-0.96
    p5-XML-SAX-Expat-0.40
    p5-XML-Simple-2.18
    p5-type1inst-0.6.1_5
    pango-1.28.3
    pciids-20101107
    pcre-8.10
    perl-5.10.1_3
    phonon-4.4.2
    phonon-gstreamer-4.4.2
    phonon-xine-4.4.2
    pinentry-qt4-0.8.0_2
    pixman-0.18.4
    png-1.4.4
    portaudio-18.1_2
    portaudit-0.5.15
    portupgrade-2.4.8,2
    printproto-1.0.4
    pth-2.0.7
    pulseaudio-0.9.22
    pwcbsd-1.4.1_8
    py26-cairo-1.8.10
    py26-cups-1.9.52
    py26-dbus-0.83.1_1
    py26-gobject-2.26.0
    py26-gstreamer-0.10.20
    py26-gtk-2.22.0_1
    py26-kdebindings-kde-4.5.4
    py26-kdebindings-krosspython-4.5.4
    py26-kdebindings-pykdeuic4-4.5.4
    py26-librtfcomp-1.1
    py26-libxml2-2.7.8_1
    py26-libxslt-1.1.26_2
    py26-notify-0.1.1_7
    py26-qt-3.18.2,2
    py26-qt4-core-4.8.1,1
    py26-qt4-dbus-4.8.1,1
    py26-qt4-gui-4.8.1,1
    py26-qt4-network-4.8.1,1
    py26-qt4-phonon-4.8.1
    py26-qt4-svg-4.8.1,1
    py26-qt4-webkit-4.8.1
    py26-qt4-xml-4.8.1,1
    py26-setuptools-0.6c11
    py26-sip-4.11.2,1
    py26-sqlite3-2.6.6_1
    py26-synce-librapi2-0.14
    py26-synce-librra-0.14
    py26-xdg-0.19
    py26-xml-0.8.4_2
    pyrex-0.9.9
    python26-2.6.6
    python27-2.7.1_1
    qca-2.0.3
    qca-ossl-2.0.0.b3_4
    qimageblitz-0.0.6
    qmake-3.3.8_1
    qt-3.3.8_12
    qt4-4.7.1
    qt4-accessible-4.7.1
    qt4-assistant-4.7.1
    qt4-clucene-4.7.1
    qt4-codecs-cn-4.7.1
    qt4-codecs-jp-4.7.1
    qt4-codecs-kr-4.7.1
    qt4-codecs-tw-4.7.1
    qt4-corelib-4.7.1
    qt4-dbus-4.7.1
    qt4-declarative-4.7.1
    qt4-designer-4.7.1
    qt4-doc-4.7.1
    qt4-graphicssystems-opengl-4.7.1
    qt4-gui-4.7.1
    qt4-l10n-4.7.1
    qt4-linguist-4.7.1
    qt4-makeqpf-4.7.1
    qt4-moc-4.7.1
    qt4-multimedia-4.7.1
    qt4-mysql-plugin-4.7.1
    qt4-network-4.7.1
    qt4-opengl-4.7.1
    qt4-pixeltool-4.7.1
    qt4-porting-4.7.1
    qt4-qdbusviewer-4.7.1
    qt4-qmake-4.7.1
    qt4-qt3support-4.7.1
    qt4-qtconfig-4.7.1
    qt4-qtestlib-4.7.1
    qt4-qvfb-4.7.1
    qt4-rcc-4.7.1
    qt4-script-4.7.1
    qt4-scripttools-4.7.1
    qt4-sql-4.7.1
    qt4-sqlite-plugin-4.7.1
    qt4-svg-4.7.1
    qt4-uic-4.7.1
    qt4-uic3-4.7.1
    qt4-webkit-4.7.1
    qt4-xml-4.7.1
    qt4-xmlpatterns-4.7.1
    qt4-xmlpatterns-tool-4.7.1
    qtscriptgenerator-0.1.0_2
    qwt-5.2.1_1
    rpm-3.0.6_15
    rsync-3.0.7
    ruby-1.8.7.302,1
    ruby18-bdb-0.6.5_1
    ruby18-deplate-0.8.5
    ruby18-kdebindings-4.5.4
    samba34-3.4.9
    samba34-libsmbclient-3.4.9
    sane-backends-1.0.21_2
    sdl-1.2.14_2,2
    sdl_mixer-1.2.11_2
    sessreg-1.0.5_1
    setxkbmap-1.1.0
    skanlite-0.7
    smpeg-0.4.4_8
    smproxy-1.0.3
    speex-1.2.r1_3,1
    sqlite3-3.7.4
    strigi-0.7.2_1
    sudo-1.7.4.4_1
    swig-1.3.39_1
    synce-librapi2-0.14
    synce-librra-0.14
    synce-libsynce-0.14
    synce-sync-engine-0.14
    sysinfo-1.0.1
    t1lib-5.1.2_1,1
    taglib-1.6.3
    taglib-extras-1.0.1
    talloc-2.0.1_1
    tcl-8.5.9
    tcl-8.6.b.1_4
    tcl-modules-8.5.9
    tcl-threads-8.6.b.1_4
    tcltls-1.6_1
    telepathy-farsight-0.0.15
    telepathy-glib-0.12.5
    telepathy-qt4-0.4.0
    tex-texmflocal-1.9
    tidy-lib-090315.c_1
    tk-8.5.9
    tk-8.6.b.1_2
    tk-threads-8.6.b.1_2
    tmake-1.7_5
    trapproto-3.4.3
    twm-1.0.4
    v4l_compat-1.0.20101027
    vala-0.10.1
    vala-vapigen-0.10.1
    vcdimager-0.7.23_6
    videoproto-2.3.0
    vorbis-tools-1.4.0_1,3
    wget-1.12_2
    win32-codecs-20100303,1
    wine-1.3.7,1
    x264-0.110.1820
    xcb-proto-1.6
    xcb-util-0.3.6_1
    xcmiscproto-1.2.0
    xcmsdb-1.0.2
    xev-1.0.4
    xextproto-7.1.1
    xgc-1.0.2
    xhost-1.0.3
    xine-0.99.6_4
    xineramaproto-1.2
    xorg-7.5
    xorg-cf-files-1.0.3
    xorg-libraries-7.5
    xrdb-1.0.6
    xv-3.10a_14
    xvid-1.2.2_1,1
    xvinfo-1.1.0
    xwd-1.0.3
    xwininfo-1.0.5
    xwud-1.0.2
    
    


    Thank you everybody.
     
  23. raul_comodoro

    raul_comodoro New Member

    Messages:
    19
    Thanks Received:
    0
    This is the list of packages Amarok depends on...

    I have installed Amarok in FreeBSD 8.2, it runs perfectly, and it does not use gstreamer libraries, at least they are not part of the tree showed by the command pkg_tree.

    Using the command pkg_tree > pkg_tree.txt, this is a chunk showing Amarok dependences:

    Code:
    amarok-1.4.10_12
    |\__ xineramaproto-1.2
    |\__ xf86vidmodeproto-2.3
    |\__ xextproto-7.1.1
    |\__ videoproto-2.3.0
    |\__ scrnsaverproto-1.2.0
    |\__ renderproto-0.11
    |\__ randrproto-1.3.1
    |\__ printproto-1.0.4
    |\__ kbproto-1.0.4
    |\__ inputproto-2.0
    |\__ fixesproto-4.1.1
    |\__ dri2proto-2.2
    |\__ damageproto-1.2.0
    |\__ compositeproto-0.4.1
    |\__ font-util-1.0.2
    |\__ encodings-1.0.3,1
    |\__ expat-2.0.1_1
    |\__ gnome_subr-1.0
    |\__ dmidecode-2.10
    |\__ cyrus-sasl-2.1.23_3
    |\__ ca_root_nss-3.12.6
    |\__ openldap-client-2.4.23
    |\__ mDNSResponder-214.3.2_1
    |\__ xvid-1.2.2_1,1
    |\__ mp4v2-1.9.1
    |\__ libvpx-0.9.5
    |\__ libfame-0.9.1_3
    |\__ libdvdread-4.1.4.r1219
    |\__ pciids-20101124
    |\__ kdehier-1.0_11
    |\__ kde-xdg-env-1.0_3,1
    |\__ hicolor-icon-theme-0.12
    |\__ ruby-1.8.7.302,1
    |\__ python26-2.6.6
    |\__ perl-5.10.1_3
    |\__ png-1.4.5
    |\__ lcms-1.19_1,1
    |\__ jpeg-8_3
    |\__ libmng-1.0.10_2
    |\__ jbigkit-1.6
    |\__ tiff-4.0.0
    |\__ jasper-1.900.1_9
    |\__ curl-7.21.3
    |\__ talloc-2.0.1_1
    |\__ pkg-config-0.25_1
    |\__ libdca-0.0.5
    |\__ libart_lgpl-2.3.21,1
    |\__ pixman-0.18.4
    |\__ fftw3-3.2.2_1
    |\__ freetype2-2.4.4
    |\__ fontconfig-2.8.0,1
    |\__ bitstream-vera-1.10_4
    |\__ xproto-7.0.16
    |\__ libfontenc-1.0.5
    |\__ mkfontscale-1.0.7
    |\__ mkfontdir-1.0.5
    |\__ font-misc-meltho-1.0.1
    |\__ font-misc-ethiopic-1.0.1
    |\__ font-bh-ttf-1.0.1
    |\__ xorg-fonts-truetype-7.5
    |\__ libICE-1.0.6,1
    |\__ iceauth-1.0.3
    |\__ libSM-1.1.1_3,1
    |\__ libXdmcp-1.0.3
    |\__ libXau-1.0.5
    |\__ ilmbase-1.0.1_1
    |\__ OpenEXR-1.6.1_3
    |\__ pcre-8.12
    |\__ orc-0.4.11
    |\__ schroedinger-1.0.10
    |\__ m4-1.4.15,1
    |\__ libvolume_id-0.81.1
    |\__ libthai-0.1.5_4
    |\__ libpthread-stubs-0.3_3
    |\__ libdrm-2.4.12_1
    |\__ libxcb-1.7
    |\__ xcb-util-0.3.6_1
    |\__ libX11-1.3.3_1,1
    |\__ libxkbfile-1.0.6
    |\__ libXext-1.1.1,1
    |\__ libvdpau-0.4.1_1
    |\__ libXv-1.0.5,1
    |\__ libXScrnSaver-1.2.0
    |\__ libXxf86vm-1.1.0
    |\__ libXp-1.0.0,1
    |\__ libXi-1.3,1
    |\__ libXinerama-1.1,1
    |\__ libXfixes-4.0.4
    |\__ libXcomposite-0.4.1,1
    |\__ libXdamage-1.1.2
    |\__ libGL-7.4.4
    |\__ libGLU-7.4.4
    |\__ gpac-libgpac-0.4.5_4,1
    |\__ x264-0.110.1820
    |\__ libXt-1.0.7
    |\__ libXpm-3.5.7
    |\__ libXmu-1.0.5,1
    |\__ libXaw-1.0.7,1
    |\__ libXrender-0.9.5
    |\__ libXcursor-1.1.10
    |\__ libXrandr-1.3.0
    |\__ libXft-2.1.14
    |\__ aalib-1.4.r5_5
    |\__ libffi-3.0.9
    |\__ libexecinfo-1.1_3
    |\__ libiconv-1.13.1_1
    |\__ sdl-1.2.14_2,2
    |\__ samba34-libsmbclient-3.4.9
    |\__ libxml2-2.7.8_1
    |\__ dbus-1.4.1
    |\__ gettext-0.18.1.1
    |\__ popt-1.16
    |\__ libidn-1.16
    |\__ bison-2.4.3,1
    |\__ aspell-0.60.6_5
    |\__ libgpg-error-1.10
    |\__ libgcrypt-1.4.6
    |\__ libxslt-1.1.26_2
    |\__ gnutls-2.8.6_2
    |\__ cups-client-1.4.6
    |\__ glib-2.26.1_1
    |\__ gamin-0.1.10_4
    |\__ gio-fam-backend-2.26.1
    |\__ shared-mime-info-0.80
    |\__ gdk-pixbuf-2.22.1
    |\__ dbus-glib-0.88
    |\__ policykit-0.9_6
    |\__ eggdbus-0.6_1
    |\__ cairo-1.10.0_3,1
    |\__ gobject-introspection-0.9.12
    |\__ pango-1.28.3
    |\__ polkit-0.99
    |\__ consolekit-0.4.3
    |\__ hal-0.5.14_12
    |\__ taglib-1.6.3
    |\__ portaudio-18.1_2
    |\__ nas-1.9.2
    |\__ qt-3.3.8_12
    |\__ dbus-qt3-0.70_5
    |\__ musepack-2009.03.01_1
    |\__ libogg-1.2.2,4
    |\__ speex-1.2.r1_3,1
    |\__ libvorbis-1.3.2,3
    |\__ libtheora-1.1.1_2
    |\__ libofa-0.9.3_4
    |\__ libnjb-2.2.6_7
    |\__ libmusicbrainz-2.1.5
    |\__ libmtp-1.0.5
    |\__ libmodplug-0.8.8.1
    |\__ libmad-0.15.1b_2
    |\__ libcddb-1.3.2_1
    |\__ libaudiofile-0.2.7
    |\__ flac-1.2.1_2
    |\__ libtunepimp-0.5.3_9,1
    |\__ libsndfile-1.0.23
    |\__ libsamplerate-0.1.7_1
    |\__ faad2-2.7_3,1
    |\__ ffmpeg-0.6.1_3,1
    |\__ celt-0.7.0_1
    |\__ jackit-0.118.0_3
    |\__ cdparanoia-3.9.8_9
    |\__ libcdio-0.82_1
    |\__ vcdimager-0.7.23_6
    |\__ libxine-1.1.19_2
    |\__ artswrapper-1.5.3
    |\__ arts-1.5.10_5,1
    |\__ kdelibs-3.5.10_6
    |\__ kdebase-kompmgr-3.5.10_3
    |\__ kdebase-3.5.10_7
    |\__ atk-1.32.0
    |\__ gtk-2.22.1_1
     \__ libgpod-0.7.2_4
    


    When it was installed, just libmp3lame (lame 3.98.4) and libmodplug 0.8.8.1 where required to proper performing.