1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mount iso file

Discussion in 'General' started by register88, Jun 21, 2009.

  1. register88

    register88 New Member

    Messages:
    21
    Thanks Received:
    0
    I want mount the dvd.iso file, when i use the mdconfig, it always show this warnings:

    root@FreeBSD64/samba/movie# mdconfig -a -t vnode -f Museum2009.iso -u 0
    mdconfig: ioctl(/dev/mdctl): Permission denied

    root@FreeBSD64/samba/movie# ls -lt /dev/mdctl
    crw------- 1 root wheel 0, 71 6 21 09:40 /dev/mdctl

    My system is FreeBSD/amd64/7.2-stable.

    I can use the virtualbox mount the dvd.iso file to guest OS cdrom drive(and watch the dvd), so i think the problem shall not be the dvd.iso file.

    How to mount the dvd.iso file on FreeBSD?

    Please help, thank you.
     
  2. mk

    mk New Member

    Messages:
    300
    Thanks Received:
    16
    first check is dvd.iso already accessed by other process, then change -u 0 let say -u 55 and mount /dev/md55
     
  3. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,523
    Thanks Received:
    2,351
    Try without using -u. There may already be a /dev/md0.
     
  4. register88

    register88 New Member

    Messages:
    21
    Thanks Received:
    0
    Hi, i tried
    mdconfig -a -t vnode -f /samba/movie/Museum2009.iso
    and
    mdconfig -a -t vnode -f /samba/movie/Museum2009.iso -u 55
    the result is same.

    mdconfig: ioctl(/dev/mdctl): Permission denied

    and my system have not and md[0-9]
    ls -l /dev/md*
    crw------- 1 root wheel 0, 71 6 21 09:40 /dev/mdctl

    Thank you, please help.
     
  5. mk

    mk New Member

    Messages:
    300
    Thanks Received:
    16
    i receive permission denied when tried to use mdconfig as normal user, are you sure that you are root ?
     
  6. register88

    register88 New Member

    Messages:
    21
    Thanks Received:
    0
    Yes, i'm SURE
     
  7. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,724
    Thanks Received:
    2,137
    Have you tried with -t cd9660?
     
  8. register88

    register88 New Member

    Messages:
    21
    Thanks Received:
    0
    What is that mean?
    mount_cd9660?
    no, i have not tried, can you tell me more, i want to try it.
    please help, thank you.
     
  9. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,724
    Thanks Received:
    2,137
    mdconfig(8)

    Code:
         To create an md(4) device out of an ISO 9660 CD image file (-a and -t
         vnode are implied), using the first available md(4) device, and then
         mount the new memory disk:
    
               mount -t cd9660 /dev/`mdconfig -f cdimage.iso` /mnt
    
     
  10. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,523
    Thanks Received:
    2,351
    What are the permissions on the file you are trying to mount?
     
  11. register88

    register88 New Member

    Messages:
    21
    Thanks Received:
    0
    root@/samba/movie# mount -t cd9660 /dev/`mdconfig -f Museum2009.iso` /mnt
    mdconfig: ioctl(/dev/mdctl): Permission denied
    mount_cd9660: /dev: Block device required

    Any idea, it will Permission denied?
    ever do it as root.
     
  12. register88

    register88 New Member

    Messages:
    21
    Thanks Received:
    0
    I'm sure the file system is mount as read and write permissions.
    because i can read/write other file in this directory /samba/movie

    root@/samba/movie# ls -l Museum2009.iso
    -rwxr-xr-x 1 samba samba 4298829824 6 19 00:05 Museum2009.iso

    root@/samba/movie# mount -v /samba
    //SAMBA@PDC/SHARE on /samba (smbfs, fsid 0cff000a0a000000)
     
  13. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,724
    Thanks Received:
    2,137
    Could you try copying the iso to a local filesystem and mounting from there?
     
  14. register88

    register88 New Member

    Messages:
    21
    Thanks Received:
    0
    Sorry everyone, i know the problem now, the problem is the Museum2009.iso file is readonly.
    this command can solve it:
    mdconfig -a -t vnode -o readonly -f /samba/movie/Museum2009.iso

    Thank all.
     
  15. Carpetsmoker

    Carpetsmoker Member

    Messages:
    938
    Thanks Received:
    136
    -t cd9660 is not a valid option for mdconfig(8), this is an option for mount(8), which is very different.

    mdconfig just creates a memory disk, it does nothing with filesystems, for example:

    Code:
    # mdconfig -at vnode -f /ports/INDEX-7 
    md0
    # head -c 70 /dev/md0
    accerciser-1.6.1|/usr/ports/accessibility/accerciser|/usr/local|Intera


    As a sidenote, you should probably use UDF for DVD's, not cd9660...