1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

lxpanel needs linux-alsa-lib-1.0.10.3_2 bsd.linux-rpm.mk. Install from ports failed.

Discussion in 'Installation and Maintenance of Ports or Packages' started by dapayne12, May 1, 2010.

  1. dapayne12

    dapayne12 New Member

    Messages:
    1
    Thanks Received:
    0
    Hi,

    I got the following when performing a make install clean in x11/lxpanel. During make config I don't have ALSA selected. Why does lxpanel need Linux emulation anyway (unless I don't understand the output).

    Thanks,

    David

    Code:
    ===>  Installing for lxpanel-0.3.7_3
    ===>   lxpanel-0.3.7_3 depends on file: /compat/linux/lib/libasound.so.2 - not found
    ===>    Verifying install for /compat/linux/lib/libasound.so.2 in /usr/ports/audio/linux-alsa-lib
    ===>  linux-alsa-lib-1.0.10.3_2 bsd.linux-rpm.mk test failed: default package building at OSVERSION>=800076 was changed to linux-f10 ports, 
    please define OVERRIDE_LINUX_NONBASE_PORTS to build other linux infrastructure ports.
    *** Error code 1
    
    Stop in /usr/ports/audio/linux-alsa-lib.
    *** Error code 1
    
    Stop in /usr/ports/x11/lxpanel.
    *** Error code 1
    
    Stop in /usr/ports/x11/lxpanel.
    *** Error code 1
    
    Stop in /usr/ports/x11/lxde-meta.
    You have new mail in /var/mail/root
    [root@David-PC /usr/ports/x11/lxde-meta]#