1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

KDE 4 Black Screen

Discussion in 'KDE' started by adripillo, May 2, 2012.

  1. adripillo

    adripillo New Member

    Messages:
    410
    Likes Received:
    0
    Hello all, I have this problem. Seems that some nvidia driver had updated last Friday. Today I rebooted the computer and after login into KDE the screen became black. I tried three times and it's always the same, so I logged as a failed session and it worked but can not log in the normal way.

    Any idea or fix fo this?
     
  2. OH

    OH New Member

    Messages:
    209
    Likes Received:
    0
    Does grep "^(EE)" /var/log/Xorg.0.log tell you anything useful?
     
  3. BSDKaffee

    BSDKaffee New Member

    Messages:
    17
    Likes Received:
    0
    I am having similar issues with version 295.40 of the NVidia driver. It will work for a short time and then the screen will turn black and system will become unresponsive. I have reverted to the previous version and everything is fine now. This doesn't seem to be FreeBSD specific. I did a little research and it seems the Linux version of the driver has issues too. http://www.nvnews.net/vbulletin/showthread.php?t=178362
     
  4. adripillo

    adripillo New Member

    Messages:
    410
    Likes Received:
    0
    grep "^(EE)" /var/log/Xorg.0.log

    Code:
    # grep "^(EE)" /var/log/Xorg.0.log
    (EE) May 02 11:23:48 NVIDIA(0): Failed to initialize the GLX module; please check in your X
    (EE) May 02 11:23:48 NVIDIA(0):     log file that the GLX module has been loaded in your X
    (EE) May 02 11:23:48 NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
    (EE) May 02 11:23:48 NVIDIA(0):     you continue to encounter problems, Please try
    (EE) May 02 11:23:48 NVIDIA(0):     reinstalling the NVIDIA driver.
    
    
     
  5. adamk

    adamk New Member

    Messages:
    1,624
    Likes Received:
    0
    Show us the full Xorg log file. It looks like X is loading the wrong GLX module.

    ADam
     
  6. adripillo

    adripillo New Member

    Messages:
    410
    Likes Received:
    0
    I put the file here:

    http://pastebin.com/HT7mqwK6


    Too long to put it here.
     
  7. adripillo

    adripillo New Member

    Messages:
    410
    Likes Received:
    0
    Noob question, How do I get the old driver back?
     
  8. adamk

    adamk New Member

    Messages:
    1,624
    Likes Received:
    0
    Code:
    (II) Module glx: vendor="X.Org Foundation"
    
    You are using the Xorg GLX module. This should have been overwritten by the nvidia GLX module. I suggest reinstalling the driver.

    Adam
     
  9. adripillo

    adripillo New Member

    Messages:
    410
    Likes Received:
    0
    Done, it worked!

    But the problem now is that all menus have too much transparency. It's almost impossible to read something, I tried to select a different type of desktop teme but it still remains almost 95% of transparency. Don't know why, because it was better before.
     
  10. adripillo

    adripillo New Member

    Messages:
    410
    Likes Received:
    0
    Someone here at my side discovered/thinks that the driver loads some buffer and it crashes the driver, because when I turn off the computer and turn on the computer the problem of transparency is fixed.
     
  11. BSDKaffee

    BSDKaffee New Member

    Messages:
    17
    Likes Received:
    0
    If you are still having trouble with the new driver, I would suggest using ports-mgmt/portdowngrade to downgrade the version of the port in the ports tree. This will only revert the ports tree, not the already installed package.

    After you have done this you will have to force a rebuild of the port with portupgrade or portmaster or: # cd /usr/ports/x11/nvidia-driver && make deinstall && make reinstall

    After that you probably will want to prevent that port from being upgraded until a fix is found. You could add the following line to your /var/db/sup/refuse file to prevent the port from being updated by csup:
    Code:
    ports/x11/nvidia-driver/*
    Be sure to reboot after this since you will still have the newer kernel module loaded.
     
  12. adripillo

    adripillo New Member

    Messages:
    410
    Likes Received:
    0
    Exellent information. Thank you very much.