1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

KDE 4.4.3 Installation Problem

Discussion in 'Installation and Maintenance of Ports or Packages' started by smooky, May 20, 2010.

  1. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    Hi guys!

    Please help me to install/upgrade from KDE 4.3.5 to KDE 4.4.3. This is very hard for me always, and early always I reinstalled whole operating system if I want upgrade KDE.

    Here build log from kdelibs4:
    Code:
    automoc4: empty source file: /usr/ports/x11/kdelibs4/work/kdelibs-4.4.3/build/khtml/JSTimeRanges.cpp
    automoc4: empty source file: /usr/ports/x11/kdelibs4/work/kdelibs-4.4.3/build/khtml/JSMediaError.cpp
    ...
    (Soprano::PluginManager) found no soprano plugin at
    "/usr/local/lib/soprano/libsoprano_raptorparser.so"
    Could not find parser plugin for encoding trig
    gmake[2]: *** [nepomuk/core/pimo.h] Error code 1
    But /usr/local/lib/soprano/libsoprano_raptorparser.so file exists. :(

    Also when I installed Soprano I select Sesame2 backend...

    What's wrong?
     
  2. Anonymous

    Anonymous Guest

    Did you do what say in /usr/ports/UPDATING?
     
  3. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    Yes, I read and done as recommended: 1) 'make deinstall' all the KDE ports 2) update the rasqal, raptor, redland 3) delete the all files from /usr/local/kde4/ 4) install phonon
    then tried to install KDE...

    what's wrong?
     
  4. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    Does anyone to help me? ;-(
     
  5. zeiz

    zeiz New Member

    Messages:
    691
    Likes Received:
    0
    Doing upgrade this time I also got multiple problems with raptor, soprano, redland and so on.
    I reinstalled them all one by one starting from raptor, then something else (forgot), soprano...redland I could rebuild only as last one.
    As to now I believe kde4-4.4.3 is available as packages. I would use packages now.
     
  6. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    I dont use the packages, I need build from ports...
     
  7. zeiz

    zeiz New Member

    Messages:
    691
    Likes Received:
    0
    Up to you but... just curious: why?
     
  8. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    Because I need to specify some additional options for building, e.g. build dubug version...
    I need build from sources exactly...
    Okay, I think wiil need to clean system and reinstall all prerequisities ports, like soprano, raptor...
    Sure I could be investigate why did built failed, but have not time for now... ;-((
     
  9. hedgehog

    hedgehog New Member

    Messages:
    191
    Likes Received:
    0
    is there any port related to QT3 and/or KDE3 in your system ?
     
  10. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    i think there is no, but i'm not sure... because i have installed kdesupport from previous KDE version 4.3.5... but i'm deinstalled it...
    now i updated QT for 4.6.2 version, and rasqal, redland, soprano, virtuoso... tried build kdelibs4 but failed again... ;-(
     
  11. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    May be Soprano has something like a configuration tools, or *.conf files?
    I cant identify the problem! ;-(
    I installed Soprano with Sesame2 backend, /usr/local/bin/sopranocmd tells the 'sesame2' available, in the /usr/local/lib/soprano/*backend.so files are exists, $JAVA_HOME set to '/usr/local/diablo-jdk1.6.0'.
    What's wrong?
     
  12. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    Also I cleaned the /usr/local/kde4 and ~/.kde4 dirs...
     
  13. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    Here is all okay:

    Code:
    ldd /usr/local/lib/soprano/libsoprano_sesame2backend.so:
    	libsoprano.so.4 => /usr/local/lib/libsoprano.so.4 (0x28300000)
    	[B]libjvm.so => /usr/local/diablo-jdk1.6.0/jre/lib/i386/client/libjvm.so (0x283fb000)[/B]
    	libQtCore.so.4 => /usr/local/lib/qt4/libQtCore.so.4 (0x28be4000)
    	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28e95000)
    	libm.so.5 => /lib/libm.so.5 (0x281ca000)
    	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x281ed000)
    	libthr.so.3 => /lib/libthr.so.3 (0x28f89000)
    	libc.so.7 => /lib/libc.so.7 (0x28091000)
    	libz.so.5 => /lib/libz.so.5 (0x28f9e000)
    	libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0x281f8000)
    	libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x28fb0000)
    	libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x29075000)
    	libicui18n.so.38 => /usr/local/lib/libicui18n.so.38 (0x2916c000)
    	libintl.so.8 => /usr/local/lib/libintl.so.8 (0x292b8000)
    	libpcre.so.0 => /usr/local/lib/libpcre.so.0 (0x292c1000)
    	libicuuc.so.38 => /usr/local/lib/libicuuc.so.38 (0x292f5000)
    	libicudata.so.38 => /usr/local/lib/libicudata.so.38 (0x2940a000)
    /usr/local/bin/sopranocmd --backend sesame2

    Code:
    sopranocmd 2.4.62
       Copyright (C) 2007-2010 Sebastian Trueg <trueg@kde.org>
       This program is free software; you can redistribute it and/or modify
       it under the terms of the GNU General Public License as published by
       the Free Software Foundation; either version 2 of the License, or
       (at your option) any later version.
    
    [B]virtual bool Soprano::Virtuoso::BackendPlugin::isAvailable() const Failed to determine version of the Virtuoso server at "/usr/local
    /bin/virtuoso-t" 
    (Soprano::PluginManager) plugin  "virtuosobackend" is not available. 
    (Soprano::PluginManager) found no soprano plugin at  "/usr/local/lib/soprano/libsoprano_redlandbackend.so"[/B] 
    Usage:
       sopranocmd --backend <backendname> [--dir <storagedir>] [--port <port>] [--host <host>] [--username <username>] [--password <password>] 
    [--settings <settings>] [--serialization <s>] <command> [<parameters>]
       sopranocmd --port <port> [--host <host>] --model <name> [--serialization <s>] <command> [<parameters>]
       sopranocmd --socket <socketpath>  --model <name> [--serialization <s>] <command> [<parameters>]
       sopranocmd --dbus <dbusservice> --model <name> [--serialization <s>] <command> [<parameters>]
       sopranocmd --sparql <sparql end point> [--port <port>] [--username <username>] [--password <password>] [--serialization <s>] <command> 
    [<parameters>]
       sopranocmd --file <rdf-file> [--serialization <s>] <command> [<parameters>]
    
       --version           Print version information.
    
       --help              Print this help.
    
       --nrl               Enable NRL (Nepomuk) features. This includes the following features:
                           - Automatic query prefix expansion based on ontologies stored in the model.
                           - Automatic context creation for imported statements without a predefined context/named
                             graph. The newly created context will be of type nrl:KnowledgeBase and already have
                             its creation date set in its very own nrl:GraphMetadata.
                           - Automatic removal of metadata graphs if using the remove command with the only defined
                             node being the context.
    
       --foo               Enables scriptable output which can be used as input for other commands.
    
       --model <name>      The name of the Soprano model to perform the command on.
                           (only applicable when querying against the Soprano server.)
    
    [B]   --backend           The backend to use when accessing a storage directly and not via the Soprano server.
                           Possible backends are:
                           sesame2[b]
     
  14. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    Does anyone have clear instructions HOW UPGRADE KDE?
     
  15. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    Nothing works as usually!!! ;-)
    Now I can't install kdebindings because there are not cmake_install and CMakeLists.txt files in the python examples directory!!!
     
  16. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,672
    Likes Received:
    26
  17. smooky

    smooky New Member

    Messages:
    34
    Likes Received:
    0
    I'm really sorry!!! But I want to install KDE already 1,5 month! I can't! Nothing works! I'm already go to mad! In the kdebindings/python/pykde4/examples not found cmake_install.cmake and CMakeLists.txt files! WHYYYYYYY!???
     
  18. SIFE

    SIFE New Member

    Messages:
    472
    Likes Received:
    0
    are you using any newer version of GCC ?
     
  19. zeiz

    zeiz New Member

    Messages:
    691
    Likes Received:
    0
    May be just wait a bit: kde4-4.4.4 is in ports!
    Something could be not completed yet.
    But you still can install 4.4.3 from packages.
     
  20. cyb3ry0g

    cyb3ry0g New Member

    Messages:
    8
    Likes Received:
    0
    I try to upgrade kdelibs4 from 4.5.1 to 4.5.4 and I have the same problem:
    Code:
    Scanning dependencies of target nepomuk-rcgen
    (Soprano::PluginManager) found no soprano plugin at  "/usr/local/lib/soprano/libsoprano_raptorparser.so"
    Could not find parser plugin for encoding trig
    gmake[2]: *** [nepomuk/nuao.h] Error 1
    gmake[1]: *** [nepomuk/CMakeFiles/nepomuk.dir/all] Error 2
    
    Does anybody know, how can I solve this problem?
     
  21. beesatmsu

    beesatmsu New Member

    Messages:
    238
    Likes Received:
    0
    I hate ports...always something broken and hard to fix....no luck with packages either...also have errors...
     
  22. cyb3ry0g

    cyb3ry0g New Member

    Messages:
    8
    Likes Received:
    0
    I like ports very much, but compiling that heavy kde 4 often brings problems..
     
  23. cyb3ry0g

    cyb3ry0g New Member

    Messages:
    8
    Likes Received:
    0
    This helped me. :)