1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IPv6 not loading in FreeBSD 8.1 64 bit

Discussion in 'Networking' started by linuxunix, Nov 25, 2010.

  1. linuxunix

    linuxunix New Member

    Messages:
    73
    Likes Received:
    0
    Hello,

    I am unable to assign the Ipv6 to em0 interface. When I run this command:

    /etc/rc.d/network_ipv6 restart

    It says:

    Code:
    add net ::ffff:0.0.0.0: gateway ::1: route already in table
    add net ::0.0.0.0: gateway ::1: route already in table
    net.inet6.ip6.forwarding: 0 -> 0
    plip0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> metric 0 mtu 1500
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
            options=3<RXCSUM,TXCSUM>
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
            inet6 ::1 prefixlen 128
    net.inet6.ip6.accept_rtadv: 1 -> 1
    add net fe80::: gateway ::1: route already in table
    add net ff02::: gateway ::1: route already in table
    IPv4 mapped IPv6 address support=NO
    
    I tried assiging IPv6 through sysinstall > post-package configuration > network services > Do you want to enable Ipv6?
    But still its not assigning the same.

    Pls Help.
     
  2. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,362
    Likes Received:
    0
    Post the relevant bits from your /etc/rc.conf please.
     
  3. sk8harddiefast

    sk8harddiefast Member

    Messages:
    2,010
    Likes Received:
    4
    Your rc.conf should have:
    Code:
    ipv6_enable="YES"
    ifconfig_em0="inet [B]your ipv6[/B] netmask 255.255.255.0"
     
  4. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,362
    Likes Received:
    0
    This is wrong. It's:
    Code:
    ipv6_ifconfig_em0="<IPv6 Address> prefixlen <prefix>"
    
     
  5. sk8harddiefast

    sk8harddiefast Member

    Messages:
    2,010
    Likes Received:
    4
    Ooops. You have right!