1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installation error

Discussion in 'Installing and Upgrading FreeBSD' started by tooker, Feb 11, 2010.

  1. tooker

    tooker New Member

    Messages:
    11
    Thanks Received:
    0
    Hello all.
    I have a problem while running the installation of FreeBSD-Release 8.0 (FreeBSD-Release 7.2 too) on my system.
    Main components are:
    MB - Intel S3000AH
    CPU - Intel Pentium Dual Core E2140
    RAM - 6 GB with ECC
    Controller - Intel SASWT4I (the same as LSI 3041E-R) on LSI 1064E chipset
    HDD - IDE Hitachi 250 Gb for system install

    The problem is poissible with Intel controller, because when i remove it everything run well without errors.

    Here's the last messages of the boot stage:
    Code:
      cpu0:<ACPI CPU> on acpi0
      est0:<Enchanced Speedstep Frequency Control> on cpu0
      p4tcc0:<CPU Frequency Thermal Contrlol> on cpu0
      cpu1:<ACPI CPU> on acpi0
      est1:<Enchanced Speedstep Frequency Control> on cpu1
      p4tcc1:<CPU Frequency Thermal Contrlol> on cpu1
      NMI ISA a8, EISA 0 
      RAM parity error, likely hardware failure 
    
      fatal trap 19: non-maskable interrupt trap while in kernel mode 
      instruction pointer     = 0xNMI ISA b0, EISA ff 
      RAM parity error, likely hardware failure 
    
      fatal trap 19: non-maskable interrupt trap while in kernel mode
      cpuid = 0; epic id = 00 
      instruction pointer     = 0x20:0xFFFFFFFF8020f17a 
      stack pointer           = 0x28:0xFFFFFFFF80c61140 
      frame pointer           = 0x28:0xFFFFFFFF80e1ec30 
      code segment            = base 0x0, limit 0xfffff, type 0x1b 
                              = DPL 0, pres 1, long 1, def32 0, gran 1 
      processor eflags        = interrupt enabled, IOPL = 0 
      current process         = 0 (swapper) 
      trap number             = 19 
      panic: non-maskable interrupt trap 
      cpuid = 0 
      uptime = 1s 
    


    Could someone suggest how to fix it?
     
  2. JimW

    JimW New Member

    Messages:
    95
    Thanks Received:
    10
    Your problem could be related to your memory configuration.

    Have you tried installing the operating system with just the first DIMM slot populated? If not, give that a try.

    You said you had 6GB of memory (I assume that means 3 x 2GB sticks). I could be wrong, but I think that type of motherboard might require populating the DIMM slots with like pairs and either using 2 or all four slots. I'm not sure if you can use just 3 slots.

    Try removing some memory and see what happens.
     
  3. volatilevoid

    volatilevoid New Member

    Messages:
    173
    Thanks Received:
    20
    From the technical product specification, page 38:
    Install just 2 modules in the two blue slots and try again. If that doesn't help, get Memtest86 and check your memory.
     
  4. tooker

    tooker New Member

    Messages:
    11
    Thanks Received:
    0
    I don't think the problem is in memory. I tried to boot only with two modules, but the boot process stoped at the same place.
    Only removing of Intel controller helps.
    When i boot with controller installed the process pause for about 5 seconds after loading mpt driver. Is this normal?

    p.s. memory configuration is: 2x2 Gb & 2x1 Gb. All are Kingston KVR667D2E5 and posted in HCL of my mainboard.
     
  5. JimW

    JimW New Member

    Messages:
    95
    Thanks Received:
    10
    Does the machine continue to boot up to a login prompt after this pause?

    Does your motherboard have any other PCI x4 slots that you can switch the controller to? Have you checked any settings within the controller's setup options?

    If the machine does eventually boot with the controller installed, post the output of pciconf -lv

    Maybe also post the contents of /var/run/dmesg.boot

    It's always possible the controller could be faulty. Do you have another machine you could temporarily give it a try to see if it works?
     
  6. tooker

    tooker New Member

    Messages:
    11
    Thanks Received:
    0
    After this pause the boot process continue only to the lines in my first post.
    In the other PCI-E x8 slot the same problem occur (NMI ISA b0, EISA 0, other lines are the same as in first post). So I can only post the results of pciconf & dmesg.boot without controller installed in the system.
    The controller seems to be working. There is no problems with it on Windows Server 2003.
     
  7. tooker

    tooker New Member

    Messages:
    11
    Thanks Received:
    0
    Here is /var/run/dmesg.boot and pciconf -lv without controller installed:

    Code:
    /var/run/dmesg.boot
    
    Copyright (c) 1992-2009 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    	The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 8.0-RELEASE-p2 #0: Tue Jan  5 21:11:58 UTC 2010
        root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Pentium(R) Dual  CPU  E2140  @ 1.60GHz (1601.55-MHz K8-class CPU)
      Origin = "GenuineIntel"  Id = 0x6fd  Stepping = 13
      Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
      Features2=0xe39d<SSE3,DTES64,MON,DS_CPL,EST,TM2,SSSE3,CX16,xTPR,PDCM>
      AMD Features=0x20100800<SYSCALL,NX,LM>
      AMD Features2=0x1<LAHF>
      TSC: P-state invariant
    real memory  = 6442450944 (6144 MB)
    avail memory = 6186491904 (5899 MB)
    ACPI APIC Table: <INTEL  S3000AH>
    FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    FreeBSD/SMP: 1 package(s) x 2 core(s)
     cpu0 (BSP): APIC ID:  0
     cpu1 (AP): APIC ID:  1
    ioapic0: Changing APIC ID to 5
    ioapic0 <Version 2.0> irqs 0-23 on motherboard
    kbd1 at kbdmux0
    acpi0: <INTEL S3000AH> on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
    Timecounter "HPET" frequency 14318180 Hz quality 900
    acpi_button0: <Sleep Button> on acpi0
    pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
    pci0: <ACPI PCI bus> on pcib0
    pcib1: <ACPI PCI-PCI bridge> at device 28.0 on pci0
    pci1: <ACPI PCI bus> on pcib1
    pcib2: <ACPI PCI-PCI bridge> at device 28.4 on pci0
    pci2: <ACPI PCI bus> on pcib2
    pcib3: <ACPI PCI-PCI bridge> at device 28.5 on pci0
    pci3: <ACPI PCI bus> on pcib3
    em0: <Intel(R) PRO/1000 Network Connection 6.9.14> port 0x2000-0x201f mem 0xe8180000-0xe819ffff,0xe8100000-0xe817ffff irq 17 at device 0.0 on pci3
    em0: Using MSI interrupt
    em0: [FILTER]
    em0: Ethernet address: 00:15:17:56:f6:4e
    pci3: <simple comms, UART> at device 0.3 (no driver attached)
    pci3: <serial bus> at device 0.4 (no driver attached)
    uhci0: <Intel 82801G (ICH7) USB controller USB-A> port 0x3080-0x309f irq 23 at device 29.0 on pci0
    uhci0: [ITHREAD]
    uhci0: LegSup = 0x003b
    usbus0: <Intel 82801G (ICH7) USB controller USB-A> on uhci0
    uhci1: <Intel 82801G (ICH7) USB controller USB-B> port 0x3060-0x307f irq 19 at device 29.1 on pci0
    uhci1: [ITHREAD]
    uhci1: LegSup = 0x003b
    usbus1: <Intel 82801G (ICH7) USB controller USB-B> on uhci1
    uhci2: <Intel 82801G (ICH7) USB controller USB-C> port 0x3040-0x305f irq 18 at device 29.2 on pci0
    uhci2: [ITHREAD]
    uhci2: LegSup = 0x003b
    usbus2: <Intel 82801G (ICH7) USB controller USB-C> on uhci2
    uhci3: <Intel 82801G (ICH7) USB controller USB-D> port 0x3020-0x303f irq 16 at device 29.3 on pci0
    uhci3: [ITHREAD]
    uhci3: LegSup = 0x003b
    usbus3: <Intel 82801G (ICH7) USB controller USB-D> on uhci3
    ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xe8200400-0xe82007ff irq 23 at device 29.7 on pci0
    ehci0: [ITHREAD]
    usbus4: waiting for BIOS to give up control
    usbus4: timed out waiting for BIOS
    usbus4: EHCI version 1.0
    usbus4: <Intel 82801GB/R (ICH7) USB 2.0 controller> on ehci0
    pcib4: <ACPI PCI-PCI bridge> at device 30.0 on pci0
    pci4: <ACPI PCI bus> on pcib4
    vgapci0: <VGA-compatible display> port 0x1000-0x10ff mem 0xe0000000-0xe7ffffff,0xe8040000-0xe804ffff irq 18 at device 4.0 on pci4
    em1: <Intel(R) PRO/1000 Network Connection 6.9.14> port 0x1100-0x113f mem 0xe8020000-0xe803ffff,0xe8000000-0xe801ffff irq 17 at device 5.0 on pci4
    em1: [FILTER]
    em1: Ethernet address: 00:15:17:56:f6:4f
    isab0: <PCI-ISA bridge> at device 31.0 on pci0
    isa0: <ISA bus> on isab0
    atapci0: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x30b0-0x30bf irq 18 at device 31.1 on pci0
    ata0: <ATA channel 0> on atapci0
    ata0: [ITHREAD]
    atapci1: <Intel ICH7 SATA300 controller> port 0x30c8-0x30cf,0x30e4-0x30e7,0x30c0-0x30c7,0x30e0-0x30e3,0x30a0-0x30af mem 0xe8200000-0xe82003ff irq 19 at device 31.2 on pci0
    atapci1: [ITHREAD]
    atapci1: AHCI called from vendor specific driver
    atapci1: AHCI v1.10 controller with 4 3Gbps ports, PM not supported
    ata2: <ATA channel 0> on atapci1
    ata2: [ITHREAD]
    ata3: <ATA channel 1> on atapci1
    ata3: [ITHREAD]
    ata4: <ATA channel 2> on atapci1
    ata4: [ITHREAD]
    ata5: <ATA channel 3> on atapci1
    ata5: [ITHREAD]
    pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
    atrtc0: <AT realtime clock> port 0x70-0x71,0x74-0x77 irq 8 on acpi0
    fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f0 irq 6 drq 2 on acpi0
    fdc0: [FILTER]
    atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
    atkbd0: <AT Keyboard> irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    uart0: [FILTER]
    cpu0: <ACPI CPU> on acpi0
    est0: <Enhanced SpeedStep Frequency Control> on cpu0
    p4tcc0: <CPU Frequency Thermal Control> on cpu0
    cpu1: <ACPI CPU> on acpi0
    est1: <Enhanced SpeedStep Frequency Control> on cpu1
    p4tcc1: <CPU Frequency Thermal Control> on cpu1
    orm0: <ISA Option ROM> at iomem 0xc0000-0xc8fff on isa0
    sc0: <System console> at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    ppc0: cannot reserve I/O port range
    Timecounters tick every 1.000 msec
    usbus0: 12Mbps Full Speed USB v1.0
    usbus1: 12Mbps Full Speed USB v1.0
    usbus2: 12Mbps Full Speed USB v1.0
    usbus3: 12Mbps Full Speed USB v1.0
    usbus4: 480Mbps High Speed USB v2.0
    ad0: 238475MB <HDT722525DLAT80 V44OA70A> at ata0-master UDMA100
    ugen0.1: <Intel> at usbus0
    uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
    ugen1.1: <Intel> at usbus1
    uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
    ugen2.1: <Intel> at usbus2
    uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
    ugen3.1: <Intel> at usbus3
    uhub3: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
    ugen4.1: <Intel> at usbus4
    uhub4: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus4
    SMP: AP CPU #1 Launched!
    Root mount waiting for: usbus4 usbus3 usbus2 usbus1 usbus0
    uhub0: 2 ports with 2 removable, self powered
    uhub1: 2 ports with 2 removable, self powered
    uhub2: 2 ports with 2 removable, self powered
    uhub3: 2 ports with 2 removable, self powered
    Root mount waiting for: usbus4
    Root mount waiting for: usbus4
    Root mount waiting for: usbus4
    uhub4: 8 ports with 8 removable, self powered
    Trying to mount root from ufs:/dev/ad0s1a
    ugen2.2: <American Power Conversion> at usbus2
    WARNING: attempt to domain_add(netgraph) after domainfinalize()
    
     
  8. tooker

    tooker New Member

    Messages:
    11
    Thanks Received:
    0
    Code:
    pciconf -lv
    
    hostb0@pci0:0:0:0:	class=0x060000 card=0x348e8086 chip=0x27788086 rev=0x00 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'E7230/3000/3010 Processor to I/O Controller'
        class      = bridge
        subclass   = HOST-PCI
    pcib1@pci0:0:28:0:	class=0x060400 card=0x27d08086 chip=0x27d08086 rev=0x01 hdr=0x01
        vendor     = 'Intel Corporation'
        device     = '82801G (ICH7 Family) PCIe Root Port'
        class      = bridge
        subclass   = PCI-PCI
    pcib2@pci0:0:28:4:	class=0x060400 card=0x27e08086 chip=0x27e08086 rev=0x01 hdr=0x01
        vendor     = 'Intel Corporation'
        device     = '82801GR/GH/GHM (ICH7 Family) PCIe Root Port'
        class      = bridge
        subclass   = PCI-PCI
    pcib3@pci0:0:28:5:	class=0x060400 card=0x27e28086 chip=0x27e28086 rev=0x01 hdr=0x01
        vendor     = 'Intel Corporation'
        device     = '82801GR/GH/GHM (ICH7 Family) PCIe Root Port'
        class      = bridge
        subclass   = PCI-PCI
    uhci0@pci0:0:29:0:	class=0x0c0300 card=0x348e8086 chip=0x27c88086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = '82801G (ICH7 Family) USB Universal Host Controller'
        class      = serial bus
        subclass   = USB
    uhci1@pci0:0:29:1:	class=0x0c0300 card=0x348e8086 chip=0x27c98086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = '82801G (ICH7 Family) USB Universal Host Controller'
        class      = serial bus
        subclass   = USB
    uhci2@pci0:0:29:2:	class=0x0c0300 card=0x348e8086 chip=0x27ca8086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = '82801G (ICH7 Family) USB Universal Host Controller'
        class      = serial bus
        subclass   = USB
    uhci3@pci0:0:29:3:	class=0x0c0300 card=0x348e8086 chip=0x27cb8086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = '82801G (ICH7 Family) USB Universal Host Controller'
        class      = serial bus
        subclass   = USB
    ehci0@pci0:0:29:7:	class=0x0c0320 card=0x348e8086 chip=0x27cc8086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = '82801G (ICH7 Family) USB 2.0 Enhanced Host Controller'
        class      = serial bus
        subclass   = USB
    pcib4@pci0:0:30:0:	class=0x060401 card=0x348e8086 chip=0x244e8086 rev=0xe1 hdr=0x01
        vendor     = 'Intel Corporation'
        device     = '82801 Family (ICH2/3/4/5/6/7/8/9,63xxESB) Hub Interface to PCI Bridge'
        class      = bridge
        subclass   = PCI-PCI
    isab0@pci0:0:31:0:	class=0x060100 card=0x348e8086 chip=0x27b88086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Intel 82801GB/GR (ICH7 Family) LPC Interface Controller - 27B8 (945GL)'
        class      = bridge
        subclass   = PCI-ISA
    atapci0@pci0:0:31:1:	class=0x01018a card=0x348e8086 chip=0x27df8086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = '82801G (ICH7 Family) Ultra ATA Storage Controller'
        class      = mass storage
        subclass   = ATA
    atapci1@pci0:0:31:2:	class=0x010400 card=0x348e8086 chip=0x27c38086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = '82801GB I/O Controller Hub SATA cc=RAID'
        class      = mass storage
        subclass   = RAID
    none0@pci0:0:31:3:	class=0x0c0500 card=0x348e8086 chip=0x27da8086 rev=0x01 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = '82801G (ICH7 Family) SMBus Controller'
        class      = serial bus
        subclass   = SMBus
    em0@pci0:3:0:0:	class=0x020000 card=0x348f8086 chip=0x108c8086 rev=0x03 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Intel Corporation 82573E Gigabit Ethernet Controller (Copper) (82573E)'
        class      = network
        subclass   = ethernet
    none1@pci0:3:0:3:	class=0x070002 card=0x00008086 chip=0x108f8086 rev=0x03 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Intel(R) Active Management Technology - SOL (ICH7R)'
        class      = simple comms
        subclass   = UART
    none2@pci0:3:0:4:	class=0x0c0701 card=0x00008086 chip=0x108e8086 rev=0x03 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Intel(R) Active Management Technology - KCS (ICH7R)'
        class      = serial bus
    vgapci0@pci0:4:4:0:	class=0x030000 card=0x348e8086 chip=0x515e1002 rev=0x02 hdr=0x00
        vendor     = 'ATI Technologies Inc. / Advanced Micro Devices, Inc.'
        device     = 'Radeon ES1000 (Radeon ES1000)'
        class      = display
        subclass   = VGA
    em1@pci0:4:5:0:	class=0x020000 card=0x348f8086 chip=0x10768086 rev=0x05 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Gigabit Ethernet Controller (82541EI)'
        class      = network
        subclass   = ethernet
    
     
  9. tooker

    tooker New Member

    Messages:
    11
    Thanks Received:
    0
    As i can see the boot process gone till this line:
    orm0: <ISA Option ROM> at iomem 0xc0000-0xc8fff on isa0. Maybe here is the problem?
     
  10. tooker

    tooker New Member

    Messages:
    11
    Thanks Received:
    0
    Hi again.
    Successfully solved the problem by compiling new kernel without any options and devices i don't have.
    Can't understand how it helps but the system is working now!

    p.s. don't know how to rename the topic to [Solved] prefix