1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Instal FreeBSD 8.0 (i386) under VMWare workstation 7 issues

Discussion in 'Installing and Upgrading FreeBSD' started by c_lam_2003, Jan 18, 2010.

  1. c_lam_2003

    c_lam_2003 New Member

    Messages:
    5
    Thanks Received:
    0
    Helo, I am new to FreeBSD and just finish installation FreeBSD 8.0 (i386) version under VMWare workstation 7. I can get KDE 4 run (with sound and network support), however, I have the following questions:
    1) after install the VMWare tools, the mouse and keyboard integration is ok, but FreeBSD cannot share clipboard wit my host OS (Win XP Pro) like other guest OS, also, the drag and drop file onto FreeBSD / KDE4 not work. Is there any option/flag I need to tune?
    2) I can power off the virtual machine in KDE4, but it go back to the terminal and I need to power off thru VMware's menu, is there anyway to complete power off from within KDE4?
    3) I can update the system thru freebsd-update command and pkg_add, sysinstall etc. But I would like to know is there any GUI tools inside KDE4 to handle the add/remove program and system update ? (I know PC BSD has such feature) is there any package can do this in FreeBSD ?

    Thanks.

    Regds
    LAM Chi-fung
     
  2. graudeejs

    graudeejs Well-Known Member

    Messages:
    4,594
    Thanks Received:
    632
    1) VMWare guest additions are needed for that [I don't know if they are available for your VMWare version]
    2) my guess would be that it's problem of VMWare
    3) no
     
  3. graudeejs

    graudeejs Well-Known Member

    Messages:
    4,594
    Thanks Received:
    632
    in port there are guest additions up to emulators/vmware-guestd6

    try, perhaps they will work, however it might not work at all
     
  4. c_lam_2003

    c_lam_2003 New Member

    Messages:
    5
    Thanks Received:
    0
    I tried ad get the following:
    Code:
    MYBSD# make install clean
    ===>  Vulnerability check disabled, database not found
    
    ========================================================================
    Choose "VM" -> "Install VMware Tools..." from VMware Workstation
    menu to connect VM's CD-ROM drive and installation CD image temporary.
    Press "Install" button when a dialog pops up.
    ========================================================================
    
    This port mounts /dev/acd0 to /mnt.
    
    Are you ready? [Y/n]: y
    /bin/mkdir -p /mnt
    /sbin/umount /mnt 2>&1 >/dev/null
    umount: /mnt: not a file system root directory
    *** Error code 1 (ignored)
    /sbin/umount /dev/acd0 2>&1 >/dev/null
    umount: /dev/acd0: unknown file system
    *** Error code 1 (ignored)
    /sbin/mount -t cd9660 /dev/acd0 /mnt
    mount_cd9660: /dev/acd0: Input/output error
    *** Error code 1
    
    Stop in /usr/ports/emulators/vmware-tools6.


    seems that there is some problem in the make file.... ;<

    Regds
    LAM Chi-fung
     
  5. graudeejs

    graudeejs Well-Known Member

    Messages:
    4,594
    Thanks Received:
    632
    No, it's designed for vmware 6, you're using 7, this might well be the issue
     
  6. c_lam_2003

    c_lam_2003 New Member

    Messages:
    5
    Thanks Received:
    0
    partially solved

    Hello all,

    1) I still can't use clipboard sharing and drag & drop feature

    2) now I can power off the FreeBSD, below is what I do:
    - edit kdmrc to enable root login
    - lotout and login kde as root
    - go to setting->system setting->login manager (may need to click advanced)->go to the shutdown tab->edit the Halt command
    the default command of halt is halt, edit it to shutdown -p now and kde is able to power off.

    3) I use DesktopBSD's tool (mainly package manager)
    pkg_add -r desktopbsd-tools
    and I add the program into the K menu then everything work fine :r:r:r:r

    http://www.desktopbsd.net/wiki/doku.php?id=doc:desktopbsd_tools_in_freebsd

    http://desktopbsd.net/wiki/doku.php?id=doc:package_manager

    Regds
    LAM Chi-fung