1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I can't control openresolvconf

Discussion in 'Web and Network Services' started by migle, Apr 14, 2012.

  1. migle

    migle New Member

    Messages:
    5
    Thanks Received:
    0
    I have this machine, with static IP configuration and a nameserver, and my resolv.conf keeps being overwritten by openresolv.conf in FreeBSD 9.0 release.

    You'll probably say that I need to configure /etc/resolvconf.conf properly, but I can't get it to generate the resolv.conf that I need.

    What I want in /etc/resolv.conf is:
    Code:
    domain example.com
    search example.com
    nameserver 127.0.0.1
    


    And I keep getting:
    Code:
    # Generated by resolvconf
    search example.com
    nameserver 127.0.0.1
    nameserver 10.0.0.1
    


    My /etc/resolvconf.conf is:
    Code:
    name_servers=127.0.0.1
    search_domains=example.com
    


    Heck, I think I have no DHCP-configured interfaces, but openresolvconf is probably getting that 10.0.0.1 address from DHCP for some reason. pgrep dhclient gives nothing and the configuration in /etc/rc.conf is:
    Code:
    # Network configuration
    hostname="nicehost.example.com"
    ifconfig_re0="inet 10.0.0.2/24"
    ifconfig_re0_ipv6="inet6 2000:db:1234::1/64"
    ifconfig_nfe0="inet 10.0.0.3/32"
    ifconfig_nfe0_ipv6="inet6 2000:db:1234::2/128"
    
    # Network routing options
    defaultrouter="10.0.0.1"
    ipv6_gateway_enable="YES"
    rtadvd_enable="YES"
    rtadvd_interfaces="re0"
    
    # SixXS tunnel
    sixxs_aiccu_enable="YES"
    


    I would really want openresolvconf to just disappear, but I don't understand /etc/rc.d/resolv.

    How can I do this?
    1) How can I make openresolvconf go away?
    2) If not, how can I configure it so that it never tries DHCP?

    Thanks,
     
  2. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,622
    Thanks Received:
    2,384
    # pkg_delete -x openresolv

    You don't need it.
     
  3. migle

    migle New Member

    Messages:
    5
    Thanks Received:
    0
    Oh, I wish it was that simple, SirDice. I know well I don't need it, but I didn't install it either.

    In FreeBSD 9.0 it was integrated in the base system.

    I'm pretty sure that if they included it in the base system, then there must be some knob somewhere that allows avoiding it.
    But I can't find it.

    Following your answer I went to check /etc/src.conf for some WITHOUT_OPENRESOLV knob, but there isn't one.

    I'm still in the dark.

    Thanks,
     
  4. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,765
    Thanks Received:
    1,870
    The knob appears not to have been implemented yet, but you might want to hack one yourself for now by looking at the /usr/src/tools/build/options/ directory. It looks like creating a file called WITHOUT_OPENRESOLV there and setting the eponymous knob in /ectsrc.conf should be enough.