1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GeForce FX 5200 dual monitor problem

Discussion in 'X.Org' started by kegf, Jan 23, 2009.

  1. kegf

    kegf New Member

    Messages:
    12
    Likes Received:
    0
    When I connect two monitors in my GeForce FX 5200 (second monitor connected through "DVI to VGA Adapter") second monitor not work. Whith clean DVI monitors it's work without problems. Can anyone help me?

    My xorg.conf:
    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (root@jail-6)  Fri Aug  1 03:45:20 UTC 2008
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" 1024 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/local/lib/X11/rgb"
        FontPath        "/usr/local/lib/X11/fonts/misc/:unscaled"
        FontPath        "/usr/local/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/local/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/local/lib/X11/fonts/misc/"
        FontPath        "/usr/local/lib/X11/fonts/Type1/"
        FontPath        "/usr/local/lib/X11/fonts/100dpi/"
        FontPath        "/usr/local/lib/X11/fonts/75dpi/"
        FontPath        "/usr/local/lib/X11/fonts/cyrillic/"
        FontPath        "/usr/local/lib/X11/fonts/TTF/"
        FontPath        "/usr/local/lib/X11/fonts/TrueType/"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/sysmouse"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "keyboard"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "us,ru"
        Option         "XkbVariant" ",winkeys"
        Option         "XkbRules" "xorg"
        Option         "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Acer AL1716"
        DisplaySize     320    245
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync       30.0 - 71.0
        VertRefresh     50.0 - 160.0
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce FX 5200"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce FX 5200"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
    
    # Removed Option "TwinView" "1"
    # Removed Option "metamodes" "CRT: 1280x1024 +0+0, DFP: 1024x768 +1280+0; CRT: 1024x768 +0+0, DFP: nvidia-auto-select +1024+0; CRT: 800x600 +0+0, DFP: nvidia-auto-select +800+0; CRT: 640x480 +0+0, DFP: nvidia-auto-select +640+0"
        Identifier     "Screen0"
        Device         "Device1"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "True"
        Option         "RenderAccel" "true"
        Option         "AllowGLXWithComposite" "True"
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "CRT: 1280x1024 +0+0; CRT: 1024x768 +0+0; CRT: 800x600 +0+0; CRT: 640x480 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Device0"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "DFP: 1024x768 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection
    
     
  2. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,375
    Likes Received:
    3
    It's easier to use Twinview..

    Here's mine:
    Code:
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/local/lib/X11/rgb"
        FontPath        "unix/:7100"
        FontPath        "/usr/local/lib/X11/fonts/misc/:unscaled"
        FontPath        "/usr/local/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/local/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/local/lib/X11/fonts/misc/"
        FontPath        "/usr/local/lib/X11/fonts/Type1/"
        FontPath        "/usr/local/lib/X11/fonts/100dpi/"
        FontPath        "/usr/local/lib/X11/fonts/75dpi/"
        FontPath        "/usr/local/lib/X11/fonts/cyrillic/"
        FontPath        "/usr/local/lib/X11/fonts/TTF/"
        FontPath        "/usr/local/lib/X11/fonts/OTF/"
        FontPath        "/usr/local/lib/X11/fonts/bitstream-vera"
        FontPath        "/usr/local/share/ghostscript/fonts/"
        FontPath        "/usr/local/lib/X11/fonts/webfonts/"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
        Load           "record"
        Load           "xtrap"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/sysmouse"
        Option         "Emulate3Buttons" "no"
        #Option         "ZAxisMapping" "4 5 6 7"
        Option         "Buttons" "16"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "keyboard"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Dell"
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "MSI"
        BoardName      "NX7600GT"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "True"
        Option         "DisableGLXRootClipping" "True"
        Option         "AllowGLXWithComposite" "True"
        Option         "TwinView"
        Option         "MetaModes" "1600x1200,1600x1200;1280x1024,1280x1024;1024x768,1024x768;800x600,800x600"
        Option         "TwinViewXineramaInfoOrder" "DFP,CRT"
        #Option        "ConnectedMonitor" "DFP"
        SubSection     "Display"
            Depth       24
            Modes      "1600x1200" "1280x1024" "1024x768" "800x600"
        EndSubSection
    EndSection
    
     
  3. kegf

    kegf New Member

    Messages:
    12
    Likes Received:
    0
    No, my problem is not in type of config. My second monitor simple not turn on, when I start computer. With DVI monitors it's work fine. Maybe anyone know how to enable simple CRT monitor on GeForce FX5200 DVI output.