1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

gdm/gnome/xorg problems

Discussion in 'X.Org' started by casualX, May 4, 2012.

  1. casualX

    casualX New Member

    Messages:
    5
    Likes Received:
    0
    I'm quite new to freebsd FreeBSD and migrate from gentoo and OpenBSD. freebsd FreeBSD is great but I have some problems with gdm/gnome. All the things I have installed with pkg_add from release. When running startx Gnome appears but no input devices can be used. The mouse pointer doesn't even appear and in GDM the mouse pointer freezes at loading.

    The rc.conf settings are
    Code:
    gnome_enabled="YES"
    The Xorg log has some sections which could indicate the problem.

    Code:
    (**) |-->Input Device "Mouse0"
    (**) |-->Input Device "Keyboard0"
    (==) Automatically adding devices
    (==) Automatically enabling devices
    
    (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    (WW) Disabling Mouse0
    (WW) Disabling Keyboard0
    (--) Using syscons driver with X support (version 2.0)
    (--) using VT number 9
    
    
    I will add here some log files and my xorg.conf. By the way with the standard .xinitrc I could startx and use my input devices.

    I will start a portupgrade this night and have a look at the USE flags but maybe you find another error in my config. For easy section jump I named the sections as xorg.conf, gdm.log, greeter.log.

    xorg.conf

    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/local/lib/xorg/modules"
    	FontPath     "/usr/local/lib/X11/fonts/misc/"
    	FontPath     "/usr/local/lib/X11/fonts/TTF/"
    	FontPath     "/usr/local/lib/X11/fonts/OTF"
    	FontPath     "/usr/local/lib/X11/fonts/Type1/"
    	FontPath     "/usr/local/lib/X11/fonts/100dpi/"
    	FontPath     "/usr/local/lib/X11/fonts/75dpi/"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	Load  "dri"
    	Load  "dri2"
    	Load  "extmod"
    	Load  "glx"
    	Load  "record"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/sysmouse"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	#DisplaySize	  340   190	# mm
    	Identifier   "Monitor0"
    	VendorName   "SEC"
    	ModelName    "3046"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "SWcursor"           	# [<bool>]
            #Option     "Dac6Bit"            	# [<bool>]
            #Option     "Dac8Bit"            	# [<bool>]
            #Option     "BusType"            	# [<str>]
            #Option     "CPPIOMode"          	# [<bool>]
            #Option     "CPusecTimeout"      	# <i>
            #Option     "AGPMode"            	# <i>
            #Option     "AGPFastWrite"       	# [<bool>]
            #Option     "AGPSize"            	# <i>
            #Option     "GARTSize"           	# <i>
            #Option     "RingSize"           	# <i>
            #Option     "BufferSize"         	# <i>
            #Option     "EnableDepthMoves"   	# [<bool>]
            #Option     "EnablePageFlip"     	# [<bool>]
            #Option     "NoBackBuffer"       	# [<bool>]
            #Option     "DMAForXv"           	# [<bool>]
            #Option     "FBTexPercent"       	# <i>
            #Option     "DepthBits"          	# <i>
            #Option     "PCIAPERSize"        	# <i>
            #Option     "AccelDFS"           	# [<bool>]
            #Option     "IgnoreEDID"         	# [<bool>]
            #Option     "CustomEDID"         	# [<str>]
            #Option     "DisplayPriority"    	# [<str>]
            #Option     "PanelSize"          	# [<str>]
            #Option     "ForceMinDotClock"   	# <freq>
            #Option     "ColorTiling"        	# [<bool>]
            #Option     "VideoKey"           	# <i>
            #Option     "RageTheatreCrystal" 	# <i>
            #Option     "RageTheatreTunerPort" 	# <i>
            #Option     "RageTheatreCompositePort" 	# <i>
            #Option     "RageTheatreSVideoPort" 	# <i>
            #Option     "TunerType"          	# <i>
            #Option     "RageTheatreMicrocPath" 	# <str>
            #Option     "RageTheatreMicrocType" 	# <str>
            #Option     "ScalerWidth"        	# <i>
            #Option     "RenderAccel"        	# [<bool>]
            #Option     "SubPixelOrder"      	# [<str>]
            #Option     "ClockGating"        	# [<bool>]
            #Option     "VGAAccess"          	# [<bool>]
            #Option     "ReverseDDC"         	# [<bool>]
            #Option     "LVDSProbePLL"       	# [<bool>]
            #Option     "AccelMethod"        	# <str>
            #Option     "DRI"                	# [<bool>]
            #Option     "ConnectorTable"     	# <str>
            #Option     "DefaultConnectorTable" 	# [<bool>]
            #Option     "DefaultTMDSPLL"     	# [<bool>]
            #Option     "TVDACLoadDetect"    	# [<bool>]
            #Option     "ForceTVOut"         	# [<bool>]
            #Option     "TVStandard"         	# <str>
            #Option     "IgnoreLidStatus"    	# [<bool>]
            #Option     "DefaultTVDACAdj"    	# [<bool>]
            #Option     "Int10"              	# [<bool>]
            #Option     "EXAVSync"           	# [<bool>]
            #Option     "ATOMTVOut"          	# [<bool>]
            #Option     "R4xxATOM"           	# [<bool>]
            #Option     "ForceLowPowerMode"  	# [<bool>]
            #Option     "DynamicPM"          	# [<bool>]
            #Option     "NewPLL"             	# [<bool>]
            #Option     "ZaphodHeads"        	# <str>
    	Identifier  "Card0"
    	Driver      "radeon"
    	VendorName  "ATI Technologies Inc"
    	BoardName   "RS690M [Radeon X1200 Series]"
    	BusID       "PCI:1:5:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    [ Posted in the wrong forum: http://forums.freebsd.org/showthread.php?t=2756 ]
    [ Proper formatting: http://forums.freebsd.org/showthread.php?t=8816 ]
    [ Mind your writing style: http://forums.freebsd.org/showthread.php?t=18043 ]
     
  2. casualX

    casualX New Member

    Messages:
    5
    Likes Received:
    0
    Code:
    gnome-session[1394]: WARNING: Could not launch application 'at-spi-registryd-wrapper.desktop':
     Unable to start application: Failed to execute child process "/usr/local/libexec/at-spi-registryd"
     (No such file or directory)
    gnome-session[1394]: WARNING: Could not launch application 'metacity.desktop':
     Unable to start application: Failed to execute child process "metacity" (No such file or directory)
    gnome-session[1394]: WARNING: Could not launch application 'gnome-power-manager.desktop':
     Unable to start application: Failed to execute child process "gnome-power-manager"
     (No such file or directory)
    ** (process:1404): DEBUG: Greeter session pid=1404 display=:0 xauthority=/var/run/gdm/auth-for-gdm-x1ejau/database
    
    (polkit-gnome-authentication-agent-1:1406): polkit-gnome-1-WARNING **:
     Unable to determine the session we are in: GDBus.Error:org.freedesktop.ConsoleKit.Manager.GeneralError:
     Unable to lookup session information for process '1406'
    gdm-simple-greeter[1404]: Gtk-WARNING: gtkwidget.c:5683: widget not within a GtkWindow
    
    (gnome-settings-daemon:1400): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only:
     assertion `private->update_and_descendants_freeze_count > 0' failed
    gnome-session[1394]: WARNING: Unable to determine session: Unable to lookup session information for process '1394'
     
  3. casualX

    casualX New Member

    Messages:
    5
    Likes Received:
    0
    Did a complete portupgrade. Didn't work but could install kde3 which runs smooth, so the problem is gone.