1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fluxbox - Creating Theme

Discussion in 'Other Window Managers' started by markfisher, Mar 4, 2012.

  1. markfisher

    markfisher New Member

    Messages:
    82
    Likes Received:
    0
    Hi

    I'm trying to create theme for my fluxbox and I'm trying to set the background wallpaper inside my theme.

    my theme.cfg file has:
    Code:
    background: centered
    background.pixmap: /usr/local/share/fluxbox/styles/MyStyle/pixmaps/Wallpaper.xpm
    
    when I use startx, I don't see any background image (I'm using feh).


    My .xinitrc has:
    Code:
    #!/bin/sh
    exec /usr/local/bin/fluxbox -log ~/.fluxbox/log
    
    I was wondering if anyone knows why my background is not loading?
    This might help, when exit the fluxbox using CTRL+ALT+Fn and then CTRL+C I see an error said:
    Code:
    Error: must specify one of: -solid, -mod, -gradient
    Thanks
    Mark
     
  2. T-Daemon

    T-Daemon New Member

    Messages:
    66
    Likes Received:
    0
    In the background: line of the theme file one of the followings setting must be specified: -solid, -mod, -gradient (further informations).
     
  3. markfisher

    markfisher New Member

    Messages:
    82
    Likes Received:
    0
  4. T-Daemon

    T-Daemon New Member

    Messages:
    66
    Likes Received:
    0
    Right. Sorry. Does it make any difference starting fluxbox by /usr/local/bin/startfluxbox?
     
  5. markfisher

    markfisher New Member

    Messages:
    82
    Likes Received:
    0
    Thanks for your reply.

    I finally figure it out. I had a "Background" set to nothing on overlay. That was the reason my background wasn't showing up. That error was because of that I guess.

    Now everything works. One thing I need to mention is "Background.pixmap" requires full path to image.


    Thanks for all your help.


    Mark