1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Failed to initialize GLX extension (compatible nvidia X driver not found.)

Discussion in 'X.Org' started by inurneck, Apr 23, 2012.

  1. inurneck

    inurneck New Member

    Messages:
    142
    Likes Received:
    0
    I haven't had to be here in a while, I hope you are all doing well for yourselves.
    The title here explains it all, I installed the nvidia-driver-173 port which is the one for my card as far as the nvidia website states.

    My card is an old nvidia FX5200 I had laying around, the module nvidia is in loader.conf, and when the system boots I can see its being loaded and also pulls in the agp.ko which is fine because I built the port with FreeBSD AGP (make config).

    I am not sure where to turn next. When I grep for GLX in xorg.0.log I get the error in the title. Thank you for your time, let me know if there is anything further I can tell you to allow you to assist me. Thanks. :)
     
  2. inurneck

    inurneck New Member

    Messages:
    142
    Likes Received:
    0
    what the hell

    I should have waited just a little while longer. Upon viewing this forum I came upon this thread. http://forums.freebsd.org/showthread.php?t=13918 Originally I didnt have a Xorg.conf file in /etc/X11 which I thought was ok because the system auto detected everything and worked so I didn't want to dabble with it. I installed nvidia-xconfig and ran it.. It touched a new xorg.conf, and when I reentered X everything is working. Thanks for reading. Hope this helps someone else. Just install nvidia-xconfig and run it if you do not have an xorg.conf one will be created for you. The auto detect obviously wasnt using the correct driver but nvidia-xconfig is.
     
  3. darwimy

    darwimy New Member

    Messages:
    20
    Likes Received:
    0
    If your Xorg log file says something else than this for the glx module:

    Code:
    (II) LoadModule: "glx"
    (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
    (II) Module glx: vendor="NVIDIA Corporation"
            compiled for 4.0.2, module version = 1.0.0
            Module class: X.Org Server Extension
    
    you should re-install x11/nvidia-driver. This is because the nvidia driver and xorg-server install the file with the same name! If you update x11-servers/xorg-server after installing the nvidia driver the latter file gets overwritten.