1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error: Unable to get file, when pkg_add-ing.

Discussion in 'Installation and Maintenance of Ports or Packages' started by fender0107401, May 5, 2012.

  1. fender0107401

    fender0107401 Member

    Messages:
    303
    Thanks Received:
    10
    Hi all:

    See this
    Code:
    # pkg_add -r vim octave firefox
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/Latest/vim.tbz... Done.
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/tcl-modules-8.5.11.tbz... Done.
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/tcl-8.5.11.tbz... Done.
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/lua-5.1.4_6.tbz... Done.
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/ctags-5.8.tbz... Done.
    
    **************************************************************************
    The executable for Exuberant CTAGS is installed as /usr/local/bin/exctags
    **************************************************************************
    
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/cscope-15.7a.tbz... Done.
    
    SECURITY NOTE: The VIM software has had several remote vulnerabilities
    discovered within VIM's modeline support.  It allowed remote attackers to
    execute arbitrary code as the user running VIM.  All known problems
    have been fixed, but the FreeBSD Security Team advises that VIM users
    use 'set nomodeline' in ~/.vimrc to avoid the possibility of trojaned
    text files.
    
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/Latest/octave.tbz... Done.
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/xbitmaps-1.1.1.tbz... Done.
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/libwww-5.4.0_4.tbz... Done.
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/hdf5-1.8.7.tbz... Done.
    Fetching ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/tex-texmflocal-1.9.tbz... Done.
    Error: Unable to get ftp://ftp.cn.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/All/pdflib-7.0.4.tbz: File unavailable (e.g., file not found, no access)
    


    After the installation of octave:
    Code:
    pkg_add: could not find package pdflib-7.0.4 !
    pkg_add: pkg_add of dependency 'gnuplot-4.4.3' failed!


    How to solve it.
     
  2. Beastie

    Beastie Active Member

    Messages:
    1,927
    Thanks Received:
    339
    It seems like print/pdflib is not available as package for any FreeBSD version and any architecture. I guess its license prevents it from being distributed in binary form?!

    You'll probably have to build it yourself using ports then retry installing the main package. Or maybe force (pkg_add -f) the installation of the main package, then run it and see if it really needs PDFLib or can run fine without it.
     
  3. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,528
    Thanks Received:
    2,352
    Yep.
    Code:
    RESTRICTED=	many odd restrictions on usage and distribution
    


    I don't quite understand why math/gnuplot depends on something, by default, that's not allowed to distribute. I would have expected the default to be off so it can be packaged properly.