1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Eclipse on FreeBSD?

Discussion in 'Installation and Maintenance of Ports or Packages' started by homer_3, Jan 7, 2010.

  1. homer_3

    homer_3 New Member

    Messages:
    12
    Likes Received:
    0
    I've been trying to get Eclipse-CDT working on FreeBSD. After finally getting it built, when I go to run it, it crashes. I get this error at the command line:

    Code:
    /libexec/ld-elf.so.1: /usr/local/eclipse/configuration/org.eclipse.osgi/bundles/80/1/.cp/libswt-mozilla-gtk-3349.so: Undefined symbol "NS_StringContainerInit2"
    Anyone have an idea on how to resolve this?
     
  2. homer_3

    homer_3 New Member

    Messages:
    12
    Likes Received:
    0
    From googling around, it seems to be an issue with having Firefox3 installed (which I do) and you need Firefox2. I uninstalled FF3, but does anyone know where I can get FF2 for FreeBSD? I can't seem to find anyone that has it.
     
  3. fonz

    fonz Moderator Staff Member Moderator

    Messages:
    2,437
    Likes Received:
    5
  4. homer_3

    homer_3 New Member

    Messages:
    12
    Likes Received:
    0
  5. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,384
    Likes Received:
    3
    Houston.. Com-check..

    Err.. How did you install eclipse? To the best of my knowledge /usr/local/eclipse isn't correct. Did you use the java/eclipse-cdt port?
     
  6. homer_3

    homer_3 New Member

    Messages:
    12
    Likes Received:
    0
    I can't remember where I got the install from. It wasn't /usr/local/eclipse though. I'll try out one of the FreshPorts versions.
     
  7. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,384
    Likes Received:
    3