1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't mount ntfs usb hard drive

Discussion in 'Peripheral Hardware' started by ckeen, Mar 4, 2010.

  1. ckeen

    ckeen New Member

    Messages:
    8
    Likes Received:
    0
    Hi everybody,
    this is my first post :)

    I installed FreeBSD from dvd (8.0-RELEASE-amd64) and i'm using kde4. I am unsuccessfully trying to mount an external usb hard drive which is ntfs.
    I already googled for solutions but with no success.
    Now I can mount fat usb sticks and the ntfs drive is recognized by kde. When I try to mount it Dolphin says:

    Code:
    An error occurred while accessing 'mydisk', the system responded: org.freedesktop.Hal.Device.Volume.InvalidMountOption: The option 
    '-u=1001' is not allowed for uid=1001
    I tried by editing /usr/local/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi this way:

    Code:
            <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="FreeBSD">
    
              <merge key="volume.fstype" type="string">ntfs-3g</merge>
              <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
    
    
              <!-- <append key="volume.mount.valid_options" type="strlist">-u=</append>
              <append key="volume.mount.valid_options" type="strlist">-g=</append>
              <append key="volume.mount.valid_options" type="strlist">-m=</append>
              <append key="volume.mount.valid_options" type="strlist">-a</append>
              <append key="volume.mount.valid_options" type="strlist">-i</append>
              <append key="volume.mount.valid_options" type="strlist">-C=</append>
              <append key="volume.mount.valid_options" type="strlist">-W=</append> -->
            </match>
          </match>
    If I uncomment the last section I get:

    Code:
    An error occurred while accessing 'mydisk', the system responded: 
    org.freedesktop.Hal.Device.Volume.UnknownFailure: mount: illegal option -- u 
    usage: mount [-t fstype] [-o options] target_fs mount_point

    by removing the two 'merge' lines I added, I get the same error.

    Any help will be much appcreciated.

    PS: FreeBSD rocks :)
     
  2. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,385
    Likes Received:
    5
    Have a look at the gconf settings:

    Specifically: System -> Storage -> default_options -> vfat
     
  3. ckeen

    ckeen New Member

    Messages:
    8
    Likes Received:
    0
    gconftool-2 -a /systems/storage
    and
    gconftool-2 --all-dirs /systems/storage
    give me empty output... However vfat is mounted well, my problem is ntfs (i already mount ntfs-3g local volume with fstab, using the 'mountprog' option)

    I can't mount "EXTERNAL REMOVABLE USB NTFS HARD DRIVES (with ntfs-3g)" :(
     
  4. ckeen

    ckeen New Member

    Messages:
    8
    Likes Received:
    0
    It began to work with a clean [CMD="gconftool-2 -s /system/storage/default_options/ntfs/mount_options --type=string 'mountprog=/usr/local/bin/ntfs-3g -m=755'"][/CMD]

    Thanx :)
     
  5. ckeen

    ckeen New Member

    Messages:
    8
    Likes Received:
    0
    can't self edit my wrong posts sry
    Code:
    gconftool-2 -s /system/storage/default_options/ntfs/mount_options --type=string 'mountprog=/usr/local/bin/ntfs-3g -m=755'
     
  6. irkkaaja

    irkkaaja New Member

    Messages:
    61
    Likes Received:
    0
    I'm having the same problem.

    mount -t ntfs /dev/da0s5 /mnt/ext

    works fine, but I can't write to the disk.

    mount -t ntfs-3g /dev/da0s5 /mnt/ext

    gives the error:

    Code:
    mount: /dev/da0s5: Operation not supported by device
    which is to say, ntfs works fine for my external, but ntfs-3g does not. I tried running the command pasted above, and it didn't work. Also I'm not on KDE so the posted advice doesn't mean much to me.