Hello. I have a strange issue. Yesterday I've updated ports tree with thoughts to install perl Mail-Box modules. But I couldn't do that because strange error occurred: Code: # make ===> p5-Mail-Box-2.097 requires Perl 5.8.0 or later, install lang/perl5.8, lang/perl5.10, lang/perl5.12 or lang/perl5.14 and try again. *** Error code 1 At that point I used perl5.12.4 and it worked as it should. Other (already installed) modules were also working fine. I decided to update perl from 5.12.4 to 5.14.1: Code: env DISABLE_CONFLICTS=1 portupgrade -o lang/perl5.14 -f perl-5.12.\* After that I rebuilt all ports that were dependent on perl. Code: portupgrade -fr perl Mostly of that stuff were updated but not all. Some modules refused to build with the same error as p5-Mail-Box. I've noticed that ports that refusing to build has something like Code: PERL_CONFIGURE= 5.8.1+ in their Makefile. In other hand ports that has Code: PERL_CONFIGURE= YES building and working properly. Changing this variable in Makefiles of problem ports solved this issue and make them built and installed. But I think solving this in such way not a good idea. Is this a bug or something I don't understand something so far? Also couldn't find something useful on the Internet. I'm using: Code: # uname -a FreeBSD Elf 8.2-RELEASE FreeBSD 8.2-RELEASE #5: Sat May 14 22:56:08 UTC 2011 elf@Elf:/usr/src/sys/amd64/compile/ELFKERN amd64 Sorry for my poor english and thank you in advance.