1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

build error on make install clean /usr/ports/x11/gnome-applets

Discussion in 'Installation and Maintenance of Ports or Packages' started by renlobkk, Jun 9, 2009.

  1. renlobkk

    renlobkk New Member

    Messages:
    6
    Likes Received:
    0
    Hello
    i trying to install gnome2 source build, and have big problem to install.
    wen i wont install gnome-applets on /usr/ports/x11/gnome-applets, whit make install clean command become i this error :

    Code:
    checking for GIO... gnome-config: not found
    configure: error: Package requirements (gio-2.0 >= 2.15.3) were not met:
    
    No package 'gio-2.0' found
    bud wen i search the package gio-2.0 or gio-2.15.3 i did find this package.

    Code:
    ** Error code 1
    
    Stop in /usr/ports/x11/gnome-applets.
    *** Error code 1
    
    Stop in /usr/ports/x11/gnome-applets.
    *** Error code 1
    
    Stop in /usr/ports/x11/gnome2.
    *** Error code 1
    
    Stop in /usr/ports/x11/gnome2.
    
    i m a newbee on Unix FreeBSD and will be happy wen some one can help me

    thanks
    renlobkk
     
  2. LateNiteTV

    LateNiteTV New Member

    Messages:
    391
    Likes Received:
    0
    can you post the output of
    Code:
    pkg_info | grep gio
     
  3. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,375
    Likes Received:
    3
  4. renlobkk

    renlobkk New Member

    Messages:
    6
    Likes Received:
    0
    hello all,
    LateNiteTV
    Code:
    # pkg_info | grep gio
    gio-fam-backend-2.20.2 FAM backend for GLib's GIO library
    gstreamer-plugins-gio-0.10.23,3 Gstreamer gio (Glib I/O) plugin
     
  5. renlobkk

    renlobkk New Member

    Messages:
    6
    Likes Received:
    0
    SirDice,
    i have install ports-mgmt/portmaster whit # make install clean
    than i try to do what on faq226 say
    i obtain the latest ports tree skeleton whit cvsup, than
    do the command
    Code:
    # pkgdb -Ff
    pkgdb: Command not found.
    
    # portupgrade -aOW
    portupgrade: Command not found.
    i dont thinks that gnome already installed,
    any idea ?

    thanks for your help

    renlobkk
     
  6. LateNiteTV

    LateNiteTV New Member

    Messages:
    391
    Likes Received:
    0
    portmaster can update your ports. its what i use and it works very well.
    run
    Code:
    portsnap fetch update
    then
    Code:
    pkg_info | grep "<"
    then if you want to upgrade all those ports, use
    Code:
    portmaster -a
    i wouldnt mix portupgrade and portmaster. you should stick with one or the other and seeing as you already have portmaster intalled, just use that.
     
  7. renlobkk

    renlobkk New Member

    Messages:
    6
    Likes Received:
    0
    hello LateNiteTV
    thank for your help.

    so i try to upgrade ports whit pormaster, but i become this error:

    Code:
    ===>>> Port directory: /usr/ports/x11-drivers/xf86-video-intel
    ===>>> Gathering dependency list for x11-drivers/xf86-video-intel from ports
    ===>>> Starting recursive 'make config' check
    ===>>> Recursive 'make config' check complete for x11-drivers/xf86-video-intel
    
    ===>>> Returning to update check of installed ports
    
    ===>>> Launching child to update xf86-video-nv-2.1.6 to xf86-video-nv-2.1.13_1
    
    ===>>> Port directory: /usr/ports/x11-drivers/xf86-video-nv
    ===>>> Gathering dependency list for x11-drivers/xf86-video-nv from ports
    ===>>> Starting recursive 'make config' check
    ===>>> Recursive 'make config' check complete for x11-drivers/xf86-video-nv
    
    ===>>> Returning to update check of installed ports
    
    ===>>> Launching child to update xf86-video-vesa-1.3.0_1 to xf86-video-vesa-2.1.0_2
    
    ===>>> Port directory: /usr/ports/x11-drivers/xf86-video-vesa
    ===>>> Gathering dependency list for x11-drivers/xf86-video-vesa from ports
    ===>>> Starting recursive 'make config' check
    ===>>> Recursive 'make config' check complete for x11-drivers/xf86-video-vesa
    
    ===>>> Returning to update check of installed ports
    
    ===>>> Launching child to update xf86-video-via-0.2.2_2 to xf86-video-via-0.2.2_5
    
    ===>>> Port directory: /usr/ports/x11-drivers/xf86-video-via
            ===>>> This port is marked IGNORE
            ===>>> requires pciVideoPtr typedef
    
            ===>>> If you are sure you can build it, remove the
                   IGNORE line in the Makefile and try again.
    
    ===>>> Update for xf86-video-via-0.2.2_2 failed
    
    so wen i trying to install /usr/ports/x11-drivers/xf86-video-via , become this error
    Code:
    # make install clean
    ===>  xf86-video-via-0.2.2_5 requires pciVideoPtr typedef.
    *** Error code 1
    
    Stop in /usr/ports/x11-drivers/xf86-video-via.
    
    any idea ?

    thanks
    renlobkk
     
  8. DutchDaemon

    DutchDaemon Administrator Staff Member Administrator Moderator

    Messages:
    10,644
    Likes Received:
    20
    renlobkk, use
    Code:
     tags. Your posts give me a headache.
     
  9. LateNiteTV

    LateNiteTV New Member

    Messages:
    391
    Likes Received:
    0
    are you using the via driver?
     
  10. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,375
    Likes Received:
    3
    Those commands are part of ports-mgmt/portupgrade.
    Look a little further down. The instuctions when using portmaster are just below that.


    If you don't use the xf86-video-via video driver just:
    # pkg_delete -x xf86-video-via
    And restart # portmaster -a again.
     
  11. renlobkk

    renlobkk New Member

    Messages:
    6
    Likes Received:
    0
    hello all,
    so y dont thinks that i using this driver, so i delete them and run again portmaster.

    i have now oder error, but i find some old posts on the forums wo help me. New error was whit fusefs-kmod.

    i try the solution from old posts and if is not work, will be coming again.

    thanks for your helping

    renlobkk
     
  12. renlobkk

    renlobkk New Member

    Messages:
    6
    Likes Received:
    0
    problem whit portmaster and fusefs-kmod

    hello SirDice and LateNiteTV,
    i have now a new problem whit portmaster, i become this error

    Code:
    pormaster -a
    ===>>> Launching child to update fusefs-kmod-0.3.9.p1.20080208_2 to fusefs-kmod-0.3.9.p1.20080208_5
    
    ===>>> Port directory: /usr/ports/sysutils/fusefs-kmod
            ===>>> This port is marked IGNORE
            ===>>> requires the userland sources to be installed. Set SRC_BASE if it is not in /usr/src
    
            ===>>> If you are sure you can build it, remove the
                   IGNORE line in the Makefile and try again.
    
    ===>>> Update for fusefs-kmod-0.3.9.p1.20080208_2 failed
    ===>>> Aborting update
    
    Terminated
    Terminated
    than i try what on old posts say. I put the kernel sources on /usr/src/ whit sysinstall . First from CD, but have same error so i try to put kernel sources from ftp, always whit sysinstall.
    old posts is:
    http://forums.freebsd.org/showthread.php?t=1598&highlight=fusefs-kmod
    and
    http://forums.freebsd.org/showthread.php?p=4184

    Wen i check with the following commands if sources have been copied on /usr/src, i get the following answers (before was 0)
    Code:
    # find /usr/src/sys/ -type f|wc -l
        6678
    
    and
    Code:
    # ls -la /usr/src
    total 236
    drwxr-xr-x   3 root  wheel     512 Jun 12 12:11 .
    drwxr-xr-x  17 root  wheel     512 Jun  8 19:28 ..
    -rw-r--r--   1 root  wheel    6197 Oct  2  2008 COPYRIGHT
    -rw-r--r--   1 root  wheel     413 Oct  2  2008 LOCKS
    -rw-r--r--   1 root  wheel    6691 Oct  2  2008 MAINTAINERS
    -rw-r--r--   1 root  wheel   11227 Oct  2  2008 Makefile
    -rw-r--r--   1 root  wheel   36486 Oct  4  2008 Makefile.inc1
    -rw-r--r--   1 root  wheel  141070 Oct  2  2008 ObsoleteFiles.inc
    -rw-r--r--   1 root  wheel    2824 Oct  2  2008 README
    -rw-r--r--   1 root  wheel   21932 Nov 25  2008 UPDATING
    drwxr-xr-x  60 root  wheel    1024 Jun 12 12:11 sys
    
    but on runing portmaster again, i keep getting the same error

    Code:
    portmaster -a
    now i would have some questions:
    1. How can i remove the IGNORE line in the Makefile ? and it is safe ?
    2. the following command could solve the problem ?
    Code:
    portmaster-af-x fusefs-kmod
    I ask you about this subject because i can find any other solution that proposed in the old posts and i would be finish upgrading my system whit portmaster.

    thank in advance for your help

    renlobkk
     
  13. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,375
    Likes Received:
    3
    You need to have the full source in /usr/src, not just the kernel sources.